[BUG] Particles being emited at diffrent rates

This is really annoying. I have an object with a particle system that has three non-connected parts. For some stupid reason the particles are being emitted first from the top leftmost part, then from the bottom leftmost part, and then from the rightmost part. How do I get them to emit at the same rate?


Have you considered simply making three discrete emitters all with the same particle specs?

Otherwise, it may a be a consequence of your particle system values – it was quite a while ago (making Monster Movie) but I recall seeing the particles emerging from a large flat emitter mesh in what resembled density waves that moved from one edge of the mesh to the other. I don’t recall the exact specs I changed to fix it, though, and this was quite a few Blender versions ago, so I can’t really be more specific other than to confirm seeing this kind of behavior (not a bug, btw) and being able to fix it by tweaking the particle system settings.

Wish I could be more helpful.

Probably because you have made it so. You use probably “Emit from faces” (in order), well, than it emits the particles from one face after the other.

If you want random emission you should activate random.