Bump maps acts strangley depending on Mesh size?

Here’s a problem that has been puzzling me for months. I took The time to investigate further this time and decided to ask here in case anybody encountered that kind of behavior.

When I’m painting the bump maps on that mesh, trying to create pores, the alpha brush is more likely gonna scrape off the skin instead of digging small holes. The gradient also seems to be very arsh even though it looks smooth on the UV map.
Pores%20Not%20oki
At first I thought simply tuning everything down with a math node (or strenght etc) will dial it back a bit but I’m loosing lots of details.

The next picture is a simple UV sphere on which I used THE EXACT SAME material to show the difference. (Same UV, same settings etc)


So now, the things I have determined and tried

-The brush is correctly configured to work with It

-Cleared ALL the other materials on the mesh

-Tried to unwrap on a better resolution (no difference)

It looks like the dynamic range is crippled someway

See how it digs until it shatters


But this one is smoother
DYN%20ok
-The texture mapping is done by texture painting with ‘‘alpha’’ brushes.

-The scale is applied 1,1,1

Very interesting observation here done by Nathan and some troubling outcomes.

I tried, as shown on the picture, to cut a part of the mesh on which I had the problematic bump mapping, scaled it 1/25… Now the bump works as expected. The more I scale it, the smoother the texture.

So YES it seems to work once I scale but the thing is, the model as real life measurements therefore it’s not an option for the application.

So what happens probably is the UV texture is too Hi rez for the mesh (2048x2048) when I thought the problem was the opposite. Blender, by resolving the texture, is squishing the pixels down losing the gradient of the texture.

Is this theory right? I always thought you cannot have too many pixels on your uv map but I never thought there was a pixel scale factor to avoid?

Thanks if anyone has a thought on this.

Finally found the solution in an inelegant way. Found out this is a ‘not so well’ known bug with bump maps and that’s why I was so much trying to find out what I was doing wrong…

Simply using a Divide Node seems to reduce the dynamic range that suffers from being map through ‘‘too small’’ polygons.


Let’s quit frustrations and go back to creation
mouth