Camera Following Path: Weird Warping-View Problem

Dear all,

Hi there, my name is Rachel (long story re: ‘VoradPlochenko’ lol, but my original choice for username is basically an in-joke). I’m having a problem with the view going all weird and warped as my Camera makes a turn while following a Path. I’m using Blender 2.48.

It’s been ages since I learned how to get the Camera to follow a Path at all, so any refresher material re: that will be helpful and appreciated. Anyway, using an old saved .blend file that has the Camera following a straight path from one end of a hallway to the other end, I have no problems.

The problems start when I edit the path and extrude it to curve around a corner. The Camera does follow the newly-curved path…but acts very oddly towards the end, jerky. And most importantly, for some reason the static non-animated objects within view of the camera suddenly appear extremely warped/distorted during the turn around the corner. Very odd!

I’ve converted the videos below to .wmv format for ease of playback for as many of you as possible.

Here’s video of the straight path in two hallways (no problems):

And here’s video of the weird warping in the second hallway when the path is curved as I described (problems):

It seems to me like I basically need some serious refresher information as to how all of this Camera / Path stuff works at all, as well as what’s causing this warping view. I don’t even remember the specific set of instructions for how to connect the Camera and the Path, something about Parenting I think. I sound like such a noob. :yes:

Anyway…many thanks in advance for your help! Please don’t be shy to be detailed (just bear in mind, I am coming at this from a noobish perspective). Any links to tutorials, further information, and so forth will also be appreciated. hugs


Rachel :slight_smile:

When you extruded the path you altered the speed of the curve, that explains the speeding up. What I typically do, if I know how many points I am going to need, is to select two points and do a sub-divide, instead of adding to the end. You still end up with your third point, it just ends up in the middle of the curve. Then just move the points to where you need them.

The stretching of the image s strange indeed, I would guess you camera is getting scaled, perhaps? If you post the BLEND file, it would be easier to figure out.

Thanks Atom hugs. I knew the speed was off in the problem example, I just wanted to demonstrate the weird warping first before fixing the speed thing. But that is helpful info that I will put to use, good to know re: how to deal with the speed, so thanks.

Here’s the .blend:

Hopefully it can help you determine what the problem is. I’d also really appreciate if you could tell me all you can regarding how to attach a Camera to a Path, and so forth. But after we deal with the weird warping. :slight_smile:


Just giving this a bump - thanks in advance to Atom & anyone else who can help me out. hugs

Rachel :slight_smile:

delete the curve-path,
save the blend-file,
reload the blend-file
and create a new curve,
then first scale this curve,
make it turn around the corner at one end,
parent the camera to it -
the camera should no more have some wierd scaling from the curve-position.
There is something wrong, You have deleted/added different curves sometime ago,
but i cannot find where in blender some old settings are still active.
So the only quick way is to delete, save, load and check in
the object-browser there is no more curve-thing and
then add a new fresh one.

Hi Rachel,

Basically, you have non-uniform scaling on your curve object which is distorting the local space of the camera. I’m not sure exactly what your process was for getting the camera to follow the curve (I haven’t done this much either). But try doing this:

  • unparent the camera object
  • Clear the transforms of the camera with alt+G/S/R
  • Select the curve object and apply the transforms with ctrl+a -> first option
  • Select the camera and in the object menu select the ‘follow path’ constraint, and set the curve object as the name, turn on curve follow (you also already have curve follow and path turned on in the curve, but if it was a new curve those would need to be on as well), and also set FW: -Z and UP: Y in this case
  • it should now work

You can still edit the path length in the edit buttons of the curve. You may need to edit the curve a bit at the turning point because it starts turning towards the wall a little early. But otherwise you should be good to go :slight_smile: