Camera issues

Hi. I’ve clearly clicked something wrong and don’t know what :(,…
When i go to View>Camera>Active Camera, i don’t get the rectangle of the camera view on my screen. I looks like a very dark zoomed in view of nothing. I can usually make out a bit of the grid lines.
It’s only in this file. Not in new files. And if i load up with UI the problem is gone, but when i did that i lost all the materials on my objects as well.
Thanks for the assistance.
Attached is 2 pics, one of the scene with stuff in, and one of the view through the camera.
As a new user it won’t let me upload the blend file yet :confused: here’s the view through the camera.

Here’s my set up not in camera view

Have you tried delete the camera and make a new?
Its just a guess by color you looking on the face of the cupboard, what shouldnt be possible with your values.

Hi. Yep tried a new camera, same problem.
I can move the view around when in the walk through mode (forget proper name), but never see much. And the fact there’s no rectangle for the camera view confuses me.

select your camera and set it to be your active camera:

most probably you accidently hit CTR+Numpad0 which caused a random object to be your active camera. I still have no idea why this operation works for no-camera objects

Hmm thought I tried that as well, but didn’t help. I’ll have another go at it tomorrow and see if that helps. Thanks.
Maybe the forum will eventually let me share the blend file :slight_smile:

Hi. I’ve had another play this morning and resolved the issue partially.
So the issue wasn’t that it wasn’t selecting the camera, the issue was the rectangle seems to be stuck down at the bottom of the view when i’m in camera mode,… AND i was zoomed in ALOT (like,… all the way). The zoom was centre to my “view” when i was in camera mode, and this put me above the rectangle. SO i couldn’t see the camera rectangle at all, and was zoomed in so far i couldn’t see anything :P.
So todays request,. how do i get it back to looking normal? Deleting that camera and adding a new one, just seems to bring one back looking th same :/.
Any thoughts team?