Camera sort of following path

I’ve set the active camera to follow a path by parenting (Ctrl P then select “Follow Path”). I works…sort of. The camera is basically following the shape of the path as it moves, but it’s located off the path quite a distance. There is a dotted line from the camera to place on the path where the camera should be…

I’m sure it has to do with setting the origin and/or location of the path and/or the camera or both, but I can’t seem to fix it. I’ve tried everything I can think of, but I’m sure it’s a simple fix that I just don’t know about.

Both camera and path should have the same origin at 0,0,0 - to do this select both and key CTRL+A => “Location”. You may have to move the camera to the end of the curve to get it in the right place if you did not create both at 0,0,0.

Incidentally why didn’t you just add a Follow Path constraint to the Camera, rather than do a Parent thing? You could also try a Clamp To constraint with the curve as the object, then when you push the Camera it stays on the track, but you can’t keyframe offsets along the track of course.

To be honest what I do is set an Empty/other non-rendered object to follow the curve, then add a Child Of constraint to the camera with the Empty/whatever as the target so I can turn the following on and off during the animation if I want.

If all else fails, post the blend file here and I will fix it for you. :yes:

Cheers, Clock,


Unapplied rotations or scales on either object will also screw things up for you - clear with CTRL+A => “Rotation and Scale”.

Thanks. I will try your suggestions. Why I did it with parenting is because I found a series of tutorials, and the guy seemed to know what he was doing. So that’s the way he did it, by parenting, and his worked fine, but even though I followed along, mine got messed up.

I can’t Ctrl A > Location the camera. It says “Object has no data to transform”.

True! sorry about that - that’s why I use another object to do the tracking…

Cheers, Clock.

OK so I tried using an empty to follow the path/curve, and then parent the camera to the empty. But, the empty does the same thing, that is it sort of follows the SHAPE of the curve, but it is still offset by some distance, and also I get the same error when I try to “Ctrl A” the empty…no data to transform.

So I just watched ANOTHER tutorial about animating a camera along a path. In his tutorial, he DID say to do the “Ctrl A” on the camera, and when he did it, there was no error message (I was looking at his screen carefully!). The tutorial was from 2013, and he didn’t mention what version of Blender he was using. There is a LOT of inconsistency on these tutorials, Blender versions, etc. It makes it hard to learn this stuff!

You must create the camera/Empty at 0.0.0 and make the origin of the curve 0.0.0 with its first vertex at 0,0,0. Next you add the Follow Path constraint. You should check “Fixed Position” and click “Animate Path” - then you can move the curve wherever you want and the camera stays glued to its first vertex. Any other method will cause you issues!

For every good tutorial on the web for Blender, I have found many that are not so good…

Just ask here for good advice, and/or use CGCookie website.

Cheers, Clock.