Camera to view (Blender 2.8)

I try to render my test scene using “ctrl+alt+Num0” to change the camera view to the current viewport view. Now my problem is this: after “ctrl+alt+Num0” only part of the viewport view is “seen” by the camera. How to remedy this, so that the complete viewport is in “view” of the camera?

You can select your camera and hit Shift + " (button left to number 1) to go in fly mode. Then move with WASD (hold Shift for faster, Alt for slower).


You can change shortcut here:

1 Like

Good to know. Thanks…
But the problem remains, only a small part of what actually is seen in the viewport is seen by the camera.

can’t you just link/ unlink camera to view (n-panel) and zoom in/out?

If by “link” you mean “lock” (“Lock Camera to View”), that seems to work.
But I still do not understand why “ctrl+alt+num0” doesn’t result in the whole “viewport image”…

Cameras have a specific aspect due to render resolution, and this is independent to the viewport resolution.
But you can zoom in a bit to make the camera view fit the viewport more nicely…

camera and viewport are independent
totally different things

with camera just adjust to see what you need and render!

happy bl

That doesn’t explain why "ctrl-alt-num0"doesn’t work as expected

@Hirazi, like @RickyBlender said, the viewport camera and your camera object are independent. My first question is, do your viewport camera and your camera object match focal lengths? I can’t test at the moment but I’m not sure Ctrl + Alt + Numpad0 actually changes your camera object’s focal length. So, I would make sure they match before using Ctrl + Alt + Numpad0. Imagine that your viewport camera was set to 10mm and your camera object was set to 50mm, you will achieve the correct camera location and angle, but your framing will be quite zoomed in. So, take a look at your viewport properties panel and see if the viewport camera matches what you have set for your camera object’s focal length.

Again, without being able to confirm - even if it does adjust the focal length, the shape of the 3D viewport can be stretched and manipulated to almost any aspect ratio. I’m sure the programmers of Blender understood this situation when Ctrl + Alt + Numpad0 was implemented and would have to make sure the camera bounds are within the bounds of the 3D viewport. That means that at a maximum, the camera will match the shortest dimension of the 3D viewport.

Maybe some expectation managment is in order. Ctrl + Alt + Numpad0 performs an operation explained in the manual as “Move Active Camera to View”. It goes on “This feature allows you to position and orient the active camera to match your current viewport.” When you say that it doesn’t work as expected, are you expecting changes other than position and orientation?

1 Like

I check the wiki camera and tried it

it seems to work but not precisely getting the whole viewport but only a portion of it where you are in 3D

happy bl

Thank you both!
@Hunkadoodle - thanks especially for your elaboration. I understand now that my expectation was wrong! I am having a hard time adapting to new software (14 years of Softimage experience), but I am slowly getting there (I hope). :stuck_out_tongue:


Can someone point me out where did they relocate the lock camera to view toggle since n do not have the view properties like in 2.79?

Never mind i found my answer here where it is locating ;

1 Like

@polynut HOW did you enable that because that little part is not in my version of 2.8

On my version hash 741641f4c3b8, you have to click n to get the panel and then go to the view vertical tab and you should have it, but i am not sure about other 2.8 version.

Sorry for late reply a crane hit my internet cable and i was without internet since monday.

thanks it appears that i do have it but since blender 2.8 shuffles everything around it becomes frustrating to find simple things and seems more cumbersome to look for very simple things

1 Like

Glad you find it and for now it should be easier since the UI is mostly freeze except from some critical change they have to make but at the end they will make it more efficient.


I think you just want to zoom the camera. Press NUM PAD + or - and it should fill the screen or CTRL and middle mouse. The surrounding area is the passepartout ( You can adjust the opacity of this, I always assumed it was to frame an image.

You can read more about camera settings here
(for 2.8)