Camera tracking with Cycles, shadows and reflections

Hi all,

I’ve been trying it for many ours and many many days now…exacly copying the several online tutorials, and I just dont get the result that I want: camera tracking with Cycles. The tutorials that I saw are only covering the shadow-part of objects, and not the reflections of the floor. (without showing the plane ofcourse) To get rid of the tracking part and focus on the integration of created objects, I took just one frame/image of the movie were I want to place the objects in. The background image (my furniture) requires reflections and a bit of shadow too.

Can someone help me, in particular with the reflections combined with shadow and ambient oclusion.

Thanks in advance :slight_smile:

Ya know, it took me a while as well to get to a point of understanding how to composite cycles onto tracked footage. I’m not saying that I’m a compositing pro, but all of the tracked footage at my site,, is tracked in both BI and Cycles. There are two versions of tracked clips.

As my own learning curve improves, I’ve been adding in more details to the shots. Did a shot in December,, that can give you everything you want except for eliminating the default ground plane reflection on glossy objects in the scene.


Thank you for your answer and for the link. You’ve uploaded great results!! Despite your great footage and results, I 'm looking for the way to get there. Your site doen’t seem to show that :(. Although the bennefit is now that I know it is possible :slight_smile:

To composite refections onto your footage do the following steps after the usual mixing of shadows and AO and before composting your object in: create a new render layer and uncheck “combined” and “z” and then select under glossy: indirect. Then, duplicate your shadow catching object and move it to an empty layer. select that layer in the render layer we just created. Also uncheck “use environment”, and as well…select your duplicated shadow catcher, change the material to glossy and in the obejcts panel under “ray visibility”, uncheck “Glossy”. then render it out.

  1. Next, go to the compositor and add a mix node and change it to add, as well as add a new render layer node and change it to the render layer we created earlier. On the mix(or “add” node, as we have changed it to) node the top image input should be your combined shadows and footage and your bottom should be the glossy Indirect output of your render layer. Finally take the output and place it where you’d usually put your shadows + footage output.

here are some screenshots if that was to confusing:


render layer settings:

let me know if you have any questions. This is the way I’d do it, though I’m sure there’s any easier way, but this should work for now.

Hi Laustinart,

Thank you for your explaination!! I’m now trying to copy your method. I let you know when I have some questions.

Thanks again :slight_smile:

Hi Laustinart,

You described "…after the usual mixing of shadows and AO … ". Nothing here is usual for me since I just started using Blender ;-). Correct me if I am wrong but I gues the main layer contains the objects. The shadow and AO-layer contains only the shadow and AO of the ground plane. The glossy layer is shown in the lower left corner of the screenshot and contains only indirect glossy of the ground plane. But… what is placed on the “sub” layer? And why are the exclude-buttons selected? Are there more layers wich are somehow excluded from…something?

Maybe, if it doesn’t costs too much effort, you can post some screenhots of the whole compositor screen and may also a screenshot of the settings of all the layers.

Thank you in advance!!

Here is a fully screen shot of my usual node setup:

this is from my “Compositing Objects and Shadows into Video”. If you’d like you can watch that here:

To answer your question:
I create the “sub” or “Subtract” render layer to remove any excess grain on the shadows and AO(ambiant occlusion). Most of the time you won’t need this unless you’re rendering off of your CPU (like me).

Hi Laustinart,

Thank you for your screenshots, this helps me a lot!! I only have to play a bit with the sub-settings, because I render off of my gpu.
Maybe you cam help me with another related “problem”. I don’t know how I can ajust the grid so that it is in line with my background image. (single image, not a tracked movie). Now the angles and the edges of my ground plane are not parallel with the lines (of 90 degree angles) on the ground of my background image.

Cool tips, I sucked at this in BI now I can suck in Cycles too! :stuck_out_tongue: