Can I hide the floating grid?

An way to hide this grid? Sometimes it hinders my ability to see vertices when I model.

Thanks for any help with this.

Press N, a menu will popup on the right, under “Display” uncheck “Grid Floor”.


In the image it seems that your normals are inverted, if you want to fix it in edit mode select everything and press CTRL+N

‘N’ - Properties Panel, under Display section

…posted at the same time

Thanks guys…didn’t see that. Works perfect…makes life easier.