Can I move rig pivot points after generating with rigify?

Hi all,

I’ve just begun learning 3D modeling with Blender and I’m enjoying it a lot. I’ve made Gus the Gingerbread Man from the manual and now I’m doing my first human character along with Riven Phoenix’s The Structure of Blender course. I’ve rigged my model with rigify and clicked generate to advance to posing and weight painting. But I found out that I placed some of the bones in slightly the wrong locations… I’d like to move some of the joints and I’m wondering if I can do that by editing the rig somehow and not having to discard it and re-rig my model from scratch. When I went to edit mode and moved them it actually deformed the model itself. For example I moved the upper joint of the femur (thigh bone) upwards and it ended up moving the whole leg upwards and the shin area actually went inside the knee. Any way to prevent this or should I just suck it up and re-rig?

Thanks for the help guys.

PS. I tried searching the forum for an answer but couldn’t find one specifically for my problem. Sorry if it’s been answered before.

Yes you can move bones around to new place in Edit mode. Where ever you move the bone to becomes its rest position.

Thanks for your reply. But how do I move the joints in edit mode without deforming my model?

how do I move the joints in edit mode without deforming my model?

shouldn’t be a problem… try it and see…

I have tried several times but after moving the joints when I go back to object mode my model deforms. I select the rig, go into edit mode and select one of the joints and move it to the location I want. Everything at this point seems fine. But when I go back into object mode the model deforms where I moved the joint. Frustrating.

Remove parent before you change position of the bone. That means removing all vertex groups and Armature modifier from mesh object. Then bone can be repositioned.

Parent the bone again to the mesh object when you finish tweaking the bone.

It’s possible that although you have changed the rest position you still have pose transformations on the bone(s). After coming out of edit mode in pose mode you should select all bones and do alt R alt G to clear the pose, since it’s meaningless anyway after you change the bone positions in edit mode. This should return your mesh to its neutral state, still parented (you should not have to unparent in this operation, which would cause horrendous problems if you are using auto weights!) and with your bones in their new position.

It is often useful to parent the rig to a mesh using automatic weights which is best done with the rig inside the mesh, and then in edit mode move the whole rig outside the mesh to a location where you might want to animate it from. This would be impossible or very tedious to do if it were necessary to unparent and reparent it.

Thanks for your replies guys.

I haven’t stored any poses yet and I’ve always cleared every pose transformation I’ve made. Regardless I tried moving the joints around and then I went into pose mode and selected all bones and did alt r, g and s but it didn’t help. The mesh is still distorted. :confused: Maybe I’m moving the wrong things? I’m just selecting the rig and then moving the pivot points in edit mode. Should I be moving something else in another layer perhaps?

I tried attaching my blend file so you guys could take a look but the upload keeps failing. It’s under the 15mb limit. :confused: Nothing seems to work for me lmao.

Post the Blend file…
use http://www.pasteall.org/
or
http://www.blendswap.com/

then post the link here…

Thanks for the links!

Here’s the blend file: http://www.pasteall.org/blend/30286

The rig is attached to the object “Figure”. I’d appreciate it if you guys could try to move the joints around without distorting the mesh because then I’d know if I’m merely doing something wrong or if there is something wrong with the file or rig.

I really appreciate you guys helping me out!

Hummmm not sure why your not able to do this…

down load my file and try it out again…
http://www.pasteall.org/blend/30287


I see you moved the metarig and not the rig, right? I can do that too with the same results as you get but it doesn’t move the actual joints of the rig itself. If I move the joints of the metarig and then go into pose mode the joints still pivot in the original location.

Here’s what I’m trying to do:


Sorry I miss understood what you were saying… Let me take a look at it again…

okay here’s the deal…

I count a minimum of 7 other bones that depend on the location of that shoulder joint being where it is…

It would not be a good idea for you to be moving it to another location or all those other bones will get messed up in the process…

and if you are not familure with what is all going on in with all those bones… your better off not messing with them…

the best option if you must move that shoulder…

Delete the currently Generated Rigg and clear out the current Vertex Groups out of your mesh…

then use Meta Rigg to relocate the joint your wanting to mover and ReGenerate…

This is really how the Riggify Meta Rigg set up works anyway… you use to Meta Rigg to locate your joints then you generate… and then you animate…

or at least that’s the idea…

The only other suggestion that might do what ever it is your wanting to do there… is to ‘add’ more bones… that should not effect the current bone setup…

you will of coarse have to parent or constrain any added bones you have to the proper bones in the Rigg to get the proper movement…

you also will need to do a little weight painting for the new bones…

but it still might do what you need it to do…

but move this shoulder joint in the currenlty generated rigg… na… I don’t think that’s a good idea…

One other thing you can try on the one issue of the deforming mesh after moving bones in edit mode…

move your bone joint in edit mode… Tab into pose mode… hit ‘A’ to select all bones… then on the bottom tool bar pick “Pose”… then “Apply”… Then “Apply Pose as Rest Pose”… that should correct some of the distortion… (does not always work for me however)

Thanks for checking it out. Your last suggestion worked! Awesome! Thanks to everyone who helped me out on here. :slight_smile: