Can only activate one layer

I’m not sure if I touched a key to only allow one layer to be visible at a time, but Blender no longer allows multiple layers to be activated.

If I open a new Blender file clicking on other layers allows those to be visible, but shift-click does not do anything.

In other words I can only activate one layer at a time.

Is this expected behaviour?

Is there some way I can regain the ability to activate more than one layer?


Could try file menu -> load factory defaults.


Much appreciated.

I’ll get back to the machine that that’s happening on at the end of the week and I’ll try your suggestion.

It’s not happening on my laptop, though, so I’m alright at the moment.

Still cannot get layers to enable or disable.

If I import the blend file into my laptop, I can enable and disable layers normally.

However, taking the blend file across to my Desktop (with the multiple monitors) means that whatever layers were enabled using the laptop are enabled. I can select a single layer, but then all other layers are disabled.

I have removed the .config/blender directory and the .blender directory. I have removed my installation directory (I inflated the blender2.74 tar to /opt) but it makes no difference.

Difficult to see what else I can try.

Did you try with completely blank, default scene with file -> load factory defaults as suggested? That should at least tell if it’s in the file or something specific to your other installation, settings, or drivers. Loading the same file also loads UI options unless you disable that.


The new file is opened to factory defaults, but this behaviour still persists.

Very strange. Are you sure you’re using Blender that was downloaded from and not one from a linux repository. Have seen people accidentally using the repository version a couple of times because it allows them to launch it by running “blender” command.

Even the tooltip says to use shift+click on scene layers but there are other layers you could try. It’s also possible to shift+lmb hold and drag to enable/disable multiple.

Could try these

Not sure why the shift key would be special. It might be reserved by the desktop environment/window manager but having shift+lmb there doesn’t make much sense. You’re probably able to use it with everything else in Blender, like panning with shift+middle mouse, and shift+S for snap menu. If you’re not using emulate numpad option, it should also be possible to access layers with number keys and shift+number key would add/remove visible layers.

Speculating even further, no idea how Blender user preferences -> system: selection method would affect layer selection but could try changing it from auto to either of the options. Occlusion queries is quite recent addition. Could maybe also try different window draw method. Blender UI is drawn with OpenGL so at least there is a slim chance the problem could hide there.

My version is downloaded from, extracted into /opt and renamed to /opt/blender

I have a simple script file in /usr/bin/ named blender which simply runs “cd /opt/blender” and calls blender.

So no, I’m not running a repository version. :slight_smile:

Shift-lmb drag on the bottom layer icon changes the cursor to a vertical cross (with arrow heads on each arm) and drags the entire window. The ‘Properties’ panel on the right hand side also has similar behaviour.

Shift-middleMouse pans as expected and Shift-S brings the snap menu as normal.

Changing the user preference options as you suggest also does not affect the layers.


Should have tried this earlier. Sorry! :frowning:

I’m using Openbox and if I switch to KDE as the WM, the layers come back.

So it’s a Window manager problem and not a Blender problem.

Sorry for wasting your time.

~ dave

Hi: Problem solved.

I found this: which pretty much described my problem and I was able to sort it by editing the ~/.config/openbox/c.xml file and changing

<mousebind button=“S-Left” action=“Drag”> to
<mousebind button=“W-Left” action=“Drag”>

Hope this helps anyone else who might have the same problem.

Nuts. Wonder why they haven’t put that to spacebar key, no one ever uses that to anything.

Most common hotkey for window drag I’ve seen is alt+lmb and that’s fair enough, but that one is also needed in Blender. I’ve set all my window management hotkeys to super/win key since I have one and it makes more sense. I’ve also set an extra hotkey for wmctrl command to resize and move an active window to saved screen capture area and that hotkey is “Win-i”, should’ve put it to “A” but don’t know why I didn’t think of that - “A” key is much more accessible.