Can only select faces weird bug (2.8 MB)

This is one thing I have never come across in 11 years of using Blender. Brief history, I didnt like the old 2.4 interface but liked the idea of 3d modeling so I kept an eye on it once a month until 2.5 came out and decided to dive in. I’ve never regretted it. I moved from Daz 3d to making my own models and love the result. So I am a pro user and only use google nowadays to catch up on version changes and the occasional rigging issue or rare bug.

This is one of those rare bugs. I’m making a model for my webcomic, Growlution to use as a refence as I draw it. I’m not very good at drawing poses and Blender helps me out by me creating the scene and rendering it in eevee. Anyhow, I am doing a future version of the protagonist for the next update (my time not the update time) and ran into a huge snag when I went to weight paint the cat ears. I know I can just export to obj and back in again and solve it that way but that’s beside the point. I want to know what I did wrong to prevent it in the future and to help others learn from my puzzle. I’m lucky it was just the ears and not the whole model for reweight painting is out of the question.

For some strange reason The ears, just the ears are not editable in vertex or line only faces. I noticed this with the ears joined with the body. so I picked them out and tried to solve it to no avail. So I bring it to my fellow blender heads to try and solve. here are the snapshots.

Face Mode

Vertex mode I changed the angle and edited both to show you the difference

I am completely flummoxed I also included the blender file in a zip for checking, slightly modified because I’m funny that way. But the important parts are there. Can someone please help me figure this out? Thank you (File is on the top)

I couldnt believe my eyes ahahahahah! What sort of demon did u call upon this mesh :smiley: this was fun.

Ok I think its some sort of a bug. Try going to sculpt mode and come back to object mode. It should fix it… Not sure whats really going on tho!

um, nope. No change. as an FYI, I’ve tried all modes, closing blender, separating the mesh (as I mentioned) removing modifiers, groups, and everything But export/import as obj, which I know will solve it but it’s a cheap fix. I want to find the bug not a cheap fix. But I will save a version of Zeeptuar before continuing to see if it can be solved.

for me its fine (2.6 MB)

Alt+H. You have them all hidden. How you’ve managed to hide the vertices while still showing the edges and faces baffles me mind you.

If i saw this first thing in the morning- i woulve gone back to sleep

1 Like

O.O I had some technical difficulties that prevented me from posting a composed post before bed questioning 123ERTYY’s blender version because I could only get his resolution to work with 2.8.

Anyhow, perhaps it was for the best. I was honestly shocked and completely flabbergasted that alt+H worked. When I separated the meshes I had to hide the rest to select it and only clicked in face mode to pose my question. It is weird that only the verts hid and not the faces.

Thank you for solving the mystery, JohnMalcolm1970. I already worked around it but I now know what is going on if happens in the future and anyone with my problem can solve it if they search.