Can Particles change size over time?

I want particle objects to grow over time after emission. And can I apply a texture deform to a particle object based on the particles global space instead of the source objects space?

I am trying to create a dense smoke like pyroclastic smoke and use a particle emitter to create blobs.


So I have ended up with all blobs a similar size (but I have size variation active) and a repeating pattern from the noise displace on the source object.

EDIT:

Update - here is a render after applying the particle scale via particle texture.


pyro_test.blend (615 KB)

Yes, hover mouse over size in ‘render’ panel in particles section, and go to later frame, change size, hit ‘I’ over that field again.

Thanks for such a prompt reply.
Won’t that change them uniformly (as a group all over) or just fix a size at emission?

I would like the particle objects to start small and grow as they move away from the emitter.

You can use a particle blend texture with the mapping set to particle to control a parameter such as size over the lifetime of each particle

Attachments

particle_size.blend (486 KB)

Thanks Richard, I thought there was a texture approach to emission but couldn’t find the instructions anywhere.

As I cannot resolve the global texture vs local texture from the source object. I may bake out and apply displacement or maybe perform a shrink wrap of another object. Like a sock with marbles in it. Then apply displace to that…

@Richard: Thanks for posting the BLEND file. I have never been able to get that feature to work. Even with your working example file I can not re-create what you have achieved. I have set my plane up the same as your plane and particle system. I am even using the same texture that works for your emitter. For some reason, my particles will not work. If you have time, can take a look at my setup?

Attachments

265_particle_size_over_time.blend (809 KB)


I didn’t notice where the texture slot was for particles but found it now. I also cannot create a scale change based on birth from texture. But I can get it to work in the .blend provided by Richard. Hmmm.

Fixed, I didn’t set the mapping type right. It must be set to Strand/particle. And the influence should be scale (default is time).Then bake, as the live preview is a bit weird.

Found the original video demo.

It shows the basics.

I’m struggling to find what’s wrong in your file. It must be something to do with the particle system rather than the texture. All particles are emitted about frame 100 which doesn’t match up with the particle emission settings !!

I noticed a lot of failure in preview playback while varying the texture. It was tricky to balance scale and value in texture. I found using absolute black caused instability.

Thanks for looking at my file. I tried it again using a clean new BLEND file and it worked. Maybe there is a bug in using two in the same file? I think what always stumped me was I never changed the texture mapping. You have to use Strand mapping which is odd because my particles are not hair based.

Attachments

265_size_over_time_works.blend (90.1 KB)

It’s called strand/PARTICLE so I guess it does both.