Can you render the "overlays" in Blender 2.8?

I have a scene in Blender 2.8, Workbench render engine.
I want to render it, but with certain overlay’s showing in the final render. Especially the wireframe overlay (under geometry) and maybe the relationship lines…

I tried openGL rendering, but that didnt work… same with normal rendering (obviously)

So is this possible to do?

Use the View -> Viewport Render options:

Yes I tried that (the animation one, viewport render animation)…but that didnt work.

It doesnt show the overlays that I enable in the viewport:

The top one is the viewport render, and the bottom one is how I see it in my viewport (it has the wireframe overlay enabled).

So its not showing the overlays in the viewport rendering…

That’s odd. I get wireframe and relationship lines here (Win10 + nVidia) - even for the animation option.

If you’re not, it’s probably a bug that can be filed.

test

Huh that is odd indeed… But its good to know that it SHOULD work…

anybody else?

Doing a viewport render gives me exactly what’s shown in the viewport as expected. Both for Viewport Render and Viewport Render Animation.

Build from yesterday - Windows 64 bit. It works as expected with all varieties of Solid Mode (Flat, Studio and Matcap) plus LookDev and Rendered mode. Whatever overlays are turned on render,

Ah maybe there’s the problem… I didnt know there was a new build…

Ill update it and see how it goes… ill keep you guys posted

There’s a new one every day :slight_smile: I only download it once in a while though. When I haven’t done it for a while or a juicy new thing is added.

Cavity shading may affect OpenGL render.
On my machine, it may hide and minimize a little bit wireframes display.
But I did not obtain something as extreme as in your scene.

If it is still as is with a recent build, you may take a look at bugtracker and fill a report if nobody already did.

I just tested it with the new build…and cavity shading turned off

and that didnt work either… so im guessing this might be a bug

Im running it on windows 10 64 bit, AMD threadripper 2950 and GTX 1080Ti btw

Try starting Blender via “blender --factory-startup” and see if it works then. Sometimes during development some stale user prefs may lead to weird effects.

You can also use from inside Blender “File -> Load Factory Settings” (save your work first, it also loads a new scene without asking), but I found it sometimes retains some of my settings, so starting from the command line would be better.

Hi Sanne, thanks for your reply. Ill try your solution and Ill get back to you with the results