Cannot Import files (ERROR: Not a Library)

Hey all,

I’ve just started using Blender and was wanting to import a dxf file into a project, however I keep getting an “ERROR: Not a Library” dialogue every time I try it. I’ve tried different files with the same problem.
I was using Blender 2.32, then switched to 2.25 but that didn’t work.

I did notice when blender starts up there is some dialogue in a dos type window stating:

‘import site’ failed; use -v for traceback

Any assistance would be appreciated.

DXF files are not all the same, they have flavours. Try convert it to vrml1 (wrl) or obj in another app (crossroads 3DWin PolyTrans DeepExploration) and import that into Blender.

The message you get is because Python isn’t installed (you’ll need to do that to import .obj)


That sounds like you tried Appending a DXF file. By using the Open menu, DXF (and VRML too for that matter) are added to the current workspace automaticly, you don’t have to append them.


Thanks guys. Got it working now.