cannot open 2.59 file in 2.49

i am a teacher teaching blender and one of my students has downloaded blender 2.59 and completed some of the required task at home then tried to open it on blender 2.49a here at the school and a message appears:

“cannot open 250 file, some data will be lost”

and then nothing appears when opened. is there a way to open 2.59 saved files in 2.49?


try appending or linking


While the bulk of data in the files should be similar, a significant number of features/systems have changed (namely the UI layouts + animation system + Grease Pencil). If you know that the file should perhaps just contain a few models, you could try appending (File -> Append) the relevant objects from the 2.5 file in 2.49, which should get most of the data in/out safely.

Or, the easy way is to just download a .zip file bundle of Blender 2.59 from the downloads section, and run from any directory once unzipped, if installation/admin rights are the issue :wink:

thanks for that guys, however i was wondering if you perhaps explain in a bit more detail. although i teach computing, it is not my strong point. i tried the file -> append thing and it didn’t show up the student’s object he created. thanks again.

What is the point in teaching old software? Shouldn’t your students have the opportunity to get informations about state of the art software? Because all the developers who made Blender 2.5 available are thinking about new features right now. You are cutting off your students from new and amazing developments and fight old battles.

Having said this here you might get a more detailed information about blender 2.4 internals:
In blender 2.5 they cut out the graphical interface to the data however the outliner gives you a detailed insight view into every piece of data stored in Blender.

Basically a .blend-file is a huge data base storing the different aspects of a given object. Blender 2.4 can open 2.5 files only if they contain objects Blender 2.4 knows about. If you have an address manager program that can not handle mobile phone numbers or email-addresses no matter how hard you try you will never succeed in importing these additional personal information.

On the other hand nobody can give you a helping hand if you don’t supply detailed information. As it could be an OS-rights problem as well.

Blender should import the basic setup of 2.5x for instance without any problem. To break down the problem you should ask you student to save the basic scene in blender 2.5 (or even better download your own copy and try it for yourself). This scene could be used as a test scene for appending the cube mesh to a Blender 2.4x scene.

And for the sake of your students pls. consider to jump on the Blender 2.5 band wagon.
Here is a link which should help you in the transition.


In my experience, when I open a 2.5x version blender file in blender 2.49, when prompted about data being lost. you should right click on that prompt, moving the mouse away from the prompt cancels the operation and nothing happens. When right clicking on the prompt, meshes should then appear in the 3d window. (fingers crossed for good luck)

To understand what the problem is simply this, after blender 2.49 was released, the 2.5x series was a total re-coding of blender, much has changed and been updated for the future. As a result, 2.49 and 2.5x files are not 100% interchangeable… 50/50 at best…


Solution: update

blender 2.5 has been out for a while now

why are you still teaching 2.49