Cannot remove strange looking smooth shading

Somewhere during my modeling I have managed to get smooth shading that I cannot get rid of. How do I fix this?
See picture below and my *.blend example here (771.2 KB)

  • Left/Center
    Regardless of flat or smooth shading the object has some sort of “light smooth shading” going on. If I work with the mesh I can get the shading to look a bit different, but that’s about it. The only way to get rid of the smooth shading is to turn off ‘Auto Smooth’, but I want that feature for other (round) elements in my mesh - so this is not a viable workaround.
  • Right
    This is the look I want; smooth shading ON, Auto Smooth ON and hard edges working as intended. Re-building the mesh from scratch solved the problem for this example, so there is no inherent property in the vertices at least. Other than that I am lost.

Turn Auto smooth off or lower the angle.
Or just shade flat. No need of any shading on flat surfaces.

Thanks, but that does not solve it. I think I was a bit unclear.

  • Shade flat does not work. Regardless of smooth/flat setting there is a sort of “light smooth shading” that I cannot get rid of.
  • Auto smooth is needed because of round geometry in the mesh (not part of my example file).

Err… do you need Custom Split Normals Data that seems to be the issue?
Object Data Properties > Geometry Data > Clear Custom Split Normals Data

That was it! Than you very much.
I must have merged mesh from some imported geometry with custom normal settings.
I had no idea that this was an option but I have encountered this occasionally before when importing meshes - so I am very happy to have finally figured out what is going on.