Cannot render viewport with transparency

I have been trying to render some smoke using the 3D viewport’s OpenGL preview button. The idea is to save massive amounts of render time by rendering the Open GL viewport preview. Trouble is it looks like I can no longer render this preview with a transparent background. I have tried changing the Display Mode as well as enabling Transparent in the Film tab of the render panel as well as setting the image file type to PNG with alpha. Nothing works. I have heard there may be a new bug in the viewport rendering. Is this true? is there a workaround?

I hope so. Rendering smoke through Cycles is going to take a week. LIterally.