Cannot use background image or textures

I’m using Blender 2.42 on Mac OS X and I cannot add a background image. I’ve gone to the menu and selected Background Image, I told it I wanted to use a background image, and I selected the file to use. The background image window doesn’t change and no image shows up. It still looks like this…

It doesn’t matter what file type I’ve tried. I have the same problem with trying to use an image as a texture…nothing shows up or changes when I select a file. Anyone else had this problem? Is it fixable? I’ve removed and redownloaded Blender a number of times now. Any suggestions would be great!


Thanks Mike, but I already made sure that I was in Top view and that it was checkmarked as an orthographic view (yup, I even checked other postings first). Still nothing. Any other suggestions out there?

Hmm, strange.

>and I selected the file to use

Just to clarify, when you “selected the file”, did you click on the little file folder icon and navigate to a file?

If so, the only thing I can think of (which is probably unlikely) is that you’e repositioned the 3d view “camera” (not a camera object, but the implicit view camera away from the origin (0,0) (where the background image defaults to being placed.). Try pressing SH-C (View/Align View/Center cursor and view all). If it’s still not working, open the View/View Properties dialog and check under the 3d Cursor section that the cursor is at 0,0,0

If it’s still not working :

  • load a small .jpg as a background image (go through the process even though it might not appear to work

  • under the File menu choose “Pack Data”, this will “bundle” the background image inside your .blend file

  • under the File Menu select “Compress File”

  • save the file

Upload it to (or anywhere else of your choosing)

I’ll load the file and see if the background image is showing up. I’m running Win xp though, which may or may not be helpful :slight_smile:

I’ll point AndyD to this thread too, he’s an experienced Mac/Blender user.


Well, looking at the screenshot, it hasn’t loaded an image. So lets go through from the start.

Open up the Background Image panel (which you’ve done)
Choose a file by:

  • LMB on the small folder icon
  • Find your image file in the file browser, then either …
    — MMB* on a picture file (I don’t know all supported formats but jpg and png should work fine)
    — OR, LMB on picture file then press ENTER

The filepath and filename should show in the image text field.

*If you’re using a one-button mouse, Option-Click = MMB

If this doesn’t work, try loading an image via the texture palette and see if that works. To do this, go to the Texture Buttons (F6) > Texture Palette and choose Image from the texture type menu. Then, in the image panel (next to textures) press the Load Image button and try to load an image there. If this works, then the image should become available in the background image panel too (you may have to press the scroll menu button to access it). Make sure you don’t have an object selected when you do this or it will end up with this texture (you can delete the texture anyway).

If none of this works we may need more info on your OS (10.3.x or 10.4.x?) or you may have to post a blend file for us to look at.

Is it supposed to give the filename to the right of the folder icon when a file is selected? Cuz it never does, no matter how I select the image. Same thing in the texture menu. I click load image, navigate to the desired image, select it…and then nothing changes. It closes the select file window, takes me back to the main view, and it looks exactly the same. Is my Blender gibbled? I don’t know how it could be with how many times I’ve downloaded and reinstalled. Thanks for all of the time you guys are taking.

As I said above, you have to select AND load the file. If you have a 3-button mouse then select the file using the middle button/wheel - this should select AND load it. If you have a Mac one-button mouse, then Option-Click on the file to select AND load it.

The filepath and filename should appear in the text panel next to the folder icon after you’ve loaded it.

<EDIT: The following advice probably isn’t possible. I’ll leave it for now until I think about it a bit more>

Another thing to try if you’re certain you’ve tried all that.

Select (LMB) the file in the filebrowser and look at the filepath display (at the top of the filebrowser, next to the P button.) If you’ve selected a file its path should be displayed here. If so, mouse over it (don’t click on it) and press CTRL-C. This copies the path to blenders clipboard.

Then, go to the Background Image panel and press CTRL-V over the text panel there (again, don’t click on it, just mouse-over it then ctrl-v). The filepath should be displayed there now. Then, add the filename to the end of this path (type it in then press RETURN).



I had a similar problem a while back:

Interesting. I’ve never pressed that button so I have no idea what it does :slight_smile: If Frozen’s looking for it, it’s at the bottom of the filebrowser window.

Though I have to say I tried it and it worked either way in OSX.3.9, Blender 2.42.

Talking_Toaster, I love you man!! I mean, not like that, but you know. I unselected the ‘relative path’ button, and it loads the images 100%!!! That totally made my day. You rock! Oh, and thanks again AndyD, because I had no idea where the button was. And I guess I should thank Mike_S for taking the time to respond to a redundant question. I’m in an Engineer Design and Drafting Technologies program and I really want to be able to do nice 3D models of my designs. Thanks a ton!

What version of OsX are you running?

On my WinXP box, it loads bg images, textures with the relative paths button either on or off … which is why I find it strange it didn’t work for Talking_Toaster … I even tried to enter an invalid path in the top directory box in the file selector and it doesn’t accept it in 2.37, 2.41, 2.42a or CVS


I do have Windows XP installed in BootCamp, I just prefer to run Blender in Mac OS X since that’s where the computer is booted 99.5% of the time. I never use Blender in BootCamp (just games). But the last time that I used Blender on a PC I used textures and never had to hit the ‘relative path’ button.

I can’t thank you guys enough for all of your help. I’m excited to play around with it more…once I get my other 3 reports out of the way first. Gotta love school…