Can't add a background image

When I try to add a background image…nothing happens. I go to “view” and “background image…” and load - select a .jpg (with a blue dot next to it) - press “select image” and then nothing happens. Can anybody help me please?

Sounds like you’re doing everything right…I don’t know what to tell you, except maybe… try a different .jpg (maybe the one you’re trying is corrupt). Or try playing with the size (maybe you’re image is too small to see).

Is there any errors in the background window like “can not get an image”?
What Blender version are you using?

You can only see the background image when you are directly in line with one of the world axis views via NumPad 1, 3, 7, CTRL1, 3, or 7, or in camera view. Lining up with any of those views without using the NumPad will not do the trick.

I am. I am doing everything right. I have tried several different .jpg/s. I am using the most recent Blender version. I am in the front view, nothing happens when I press select image.

No errors; nothing.

Hit Numpad 5 or use the View menu to be sure you’re in Orthographic view.


Sounds like you’re missing some image libraries. Are you using an official distribution? What OS are you using? Can you post the image in question?

Strange. You could try reinstalling Blender again. Make sure to get a fresh version of the installer program. If that doesn’t work, i wonder if it’s an operating system compatibility issue. What OS are you on?

I am using Mac OS X 10.4.10 .

I deleted the old blender on my computer and installed it again from the blender website and now it works fine. Thank you so much. You do not understand how happy I am now.