Can't apply material to model

I’m pretty new to blender, so I have absolutely no idea of what I’m doing wrong, but when I try to apply a material to a closet model I made it doesn’t show up anywhere.


Just in case, I tried applying materials to other models and it works, but this one doesn’t. Can someone tell me what’s wrong?

Can you explain what is wrong. What should you be seeing that you are not. Where is all the info about your materials and example blend file that you should be supplying as a minimum FOR ALL support questions. What are we to make from the very little info supplied. Please put more effort into posing your question so we are in a position to actually know what to tell you.

Hey Waro, welcome to the forums!

Since you are using cycles, your object needs a material, and the texture must be added to your material in the node editor or texture context of the properties panel. You should also add a texture coordinate node with UV connected to your texture’s vector input. See this image:


P.S. - This won’t lead to a very nice looking material, you’ll need to build your shader a bit more. But at least you’ll be able to see it!

Sorry for taking a day to answer, I wasn’t home yesterday, and I’ll try to be more specific this time.

Anyways, I tried to do what howtoblend said, but I ended up pretty much in the same place, with the texture/model not rendering or showing up in the viewport


Tried to do the same thing with a simple cube and it works, so again, not sure what I did wrong


Although it doesn’t look very good in the cube, at least it works, unlike my previous model. Not sure what else I should post, since there is nothing else I have messed around with that I remember.

P.S. - The texture I used in the cube is the same file I’m trying to use on the closet model

Ah, I see the issue. On your closet model, you have two materials assigned. Delete the first one which is just plain white. You can use multiple materials on a model, but you have to assign which faces of the object apply to each material in edit mode by selecting them and clicking ‘assign’ under the materials list.

Well, I feel dumb now, It turns out that was the issue all along, I don’t know how that happened, It renders just fine now.

Since I’m just starting to get around the UI I probably would have never realised that was the problem if you hadn’t told me, so thank you very much.

No worries! Like with any software you have lots of little frustrations when you begin. Don’t hesitate to ask for help! It’ll save you a lot of time and effort scratching your head.

thank you so so much i was totaly stuck here couldnt render my material as usual following a you tube tutorial by someone who has no idea how to do a tutorial and has left almost all of these little details out, do you know of any good resources to learn from for the recent blender version, ive been using it about a week and im pulling my hair out trying to follow half informative tutorials

thank you again :slight_smile: :slight_smile: :slight_smile: