Can't Bake a Diffuse map: Blender keeps telling there is a texture circular dependency


I am trying to bake the diffuse map of this:

Onto this one:

I am not sure I am following the correct workflow… Though, I select the source model and the Image Texture node in to the Material Node Editor. Like this:

Then I SHIFT select the destination model and the Image Texture node in the Material Node Editor, like this:

The UV editor shows the blank texture I created for the destination model and used in its Image Texture node. Even if I switch to another texture Blender change it to this texture as soon as I press Bake button.

On the right side you can see the backing settings. Render engine is Cycles with CPU (because GPU crashed last time).

I tried also other settings but I almost always got the same results a black texture with some alpha holes. In the best case they were following the shapes of the overlapping areas.

Also Blender keep claiming that there is a circular dependency of the texture I googled and found that it means that I am trying to bake the destination texture on itself.

What is my mistake? Thanks

If I’m understanding the issue correctly.
The active image node you have selected, the one containing the empty image you’re baking to, shouldn’t be connected to anything.

It means you’re trying to modify something that is also being read. In your case that would be because the texture you’re baking to is also being read as part of a material calculation so you need to disconnect it.

All that said, your bake results will be unusable regardless. To transfer the texture data through a bake, you first need to better match the shape of the source mesh to that of the target so that the key features align. Easiest way would likely be through the use of a mesh deform modifier followed by a shrink wrap modifier.


Thanks, I resolved the annoing alert message but the baking results did not change by a single pixel. I will double check the workflow if I find a good documentation source (i.e. that doesn’t take everything for granted).

If your models have the correct scale, try setting the extrusion setting to 0.05m and the max ray distance to 0.1m. This will make the active mesh get temporarily inflated for the bake process (so it completely encases the other mesh) and then look inward for a specific distance so it can find a source for the texture.

But I have to agree with @init_pixel, even if you manage to get the bake working, the end result will be mis-aligned, the 2 characters are too different for a bake to work.

1 Like

I know they are different and that this is a problem for texture transfer. The step I am willing to achieve for now is to make this bake render something at least… I am trying now with a simple scene to see if I am able to make it work at least with some cubes… And, in fact, it worked…

I may have a few ideas to check.

  • I assume the destination character has a proper UV layout?

  • Does the source character have subsurface scattering in its material? I have had some bugs in a similar situation, try disabling it.

  • Is the source model imported from an other software? Check if the material is plugged in a weird way.

  • On the source model, try using the color texture as emissive instead of color and then bake the emit. If it works, then the problem is with the diffuse bake option.

Nevermind, I just looked at your images again and I think I found the problem.

Your first image of the materials is the material of the source mesh right? The metallic is turned all the way on. Metallic shaders don’t have a diffuse component so it can’t be baked.

1 Like

I didn’t notice that, yeah! Thank you so much. Though yes, the source model comes from Daz3D. I exported through FBX exporter the Genesis 8.1 Female (with no modifications). I am testing how to mix some workflows I found in some tutorials. I wanted to see how much work it would take to achieve such texture transfer how much of it can actually be automated, etc. I was taking in consideration the possibility to adapt the source mesh to the destination using some classic retopology methods, like Wrap Modifier and snap like suggested by other answers. But I am taking one step at a time.

1 Like

Anyway I checked in Daz3D Studio and no standard material of Genesis 8.1 Basic Female character has Metallicity (they call it like that) at 100%. Actually it is set to Zero. Therefore the error is in the Daz3D Studio FBX exporter or the Blender FBX importer.

1 Like

FBX is an old file format, created before the metallic/roughness workflow for materials was really a thing, so it can’t handle modern materials when exporting between softwares.