Can't change display mode of one object

It’s the first time I encounter this problem

I can change the display mode of the eyes but can’t seam to change the display mode of the head
It’s really annoying, If I wan’t to see how the material is doing I must go in rendered.

Thanks for listening

Please ALWAYS supply an example .blend file with any support question.

IkariShinji is absolutely correct. It’s hard to tell what the issue might be,with only a single static image and a short description.

there isnt really any good preview for cycles, you have to render.

i think what your looking for is under settings in the material tab. right under the displacment section. that will let you change the way it looks in the simple viewport solid mode.