Can't export one object only

When I export Curve B as an .obj, Curve A is exported as well, though it is not selected.

Curve B is a duplicate of Curve A – but I un-linked the two curves using U. The two curves also don’t share any materials.

I also tried converting Curve B to mesh and exporting again. Same result.

Are they somehow connected on a level that I’m not aware of?

Drives me bonkers… :grinning:

Did you " tick" the selection menu in the N pannel?

Is the second curve a true copy? Or said differently, do both curves have unique object data?
No number shown in the properties panel behind the curve name?
If so, that might be your issue here.

But again, I might be wrong :wink:

Thank you very much – that solved the problem! :+1:

I got this issue because I’m using an ancient Blender version (that fits my Octane Render version) which does not have the “Selection only” option in your screenshot.

But when I instead exported from a later Blender version, using your settings, everything worked as expected! So that’s just great, you saved my day!


Thank you very much for your reply!

In my old Blender (which was the problem), Object Data doesn’t show for curves, but when I converted to mesh it did, and the panel didn’t show a number.

So, I don’t know why that version of Blender couldn’t export correctly – but as mentioned above, newer Blender versions offer a “Selection Only” option which solves the problem…

1 Like