Can't find fonts in Blender

I’m trying to type in something with a certain font, but when I go to look for it in Blender, I can’t find it even though I have it installed in the C:/Windows directory.

How do I go about adding said font into Blender, or is there a way to do so without it crashing on me?

add a text object and go to the Text panel on the right
at bottom you will find all the font available for blender

but you could add some new one too
see wiki on how to do it

happy bl

I’m checking, and I can’t seem to find anything about adding new ones from the directory. I’m still stuck with the ones Blender’s able to read.

(font I’m trying to add is Haettenschweiler Medium, if anyone’s wondering. Also, this is a thing I’m experiencing with both 2.79 and 2.8)

font must be constant width if I remember well

check wiki for this spec

add new font

happy bl

I’ve tried that, but it doesn’t show up when I open the directory location in Blender despite having the font installed on my computer. In fact, most of my fonts don’t show up, just the small smattering Blender does want to show.

did you add the font into a folder that you can upload from ?

it should work

i think it will accept only this
you need to load a ttf like Verdana

or more

https://docs.blender.org/manual/en/latest/modeling/texts/introduction.html?highlight=font

did not test the other types !

happy bl

Yes, it’s in the c:/Windows directory. Are you inferring that Blender won’t be able to read fonts from that directory? I’m asking because they show up fine in Photoshop and in other text-oriented programs. Which is part of why I’m bringing this up in the first place- It should be reading them if they’re in the default font folder that comes with Windows.

Seems to work for me, though I am noticing that my copy is only showing me TrueType fonts (TTF) and not OpenType or other fonts (OTF). See below.

as I said I think blender font accept only TTF font !

happy bl

That’s pretty perplexing, got to wonder when they’re going to incorporate other font types.

Problem is, it’s not reading any of the TTF files I have in the default directory (the font I’m attempting to use is in the TTF format), yet it’ll read them just fine when they’re in other ones. I’m wondering how that can be possible.

As this is an old thread you have probably solved this… but just incase - before you install a font right click and choose Install for all users… it should then show up in Blender

6 Likes

Stokies!!! I’ve been to so many pages trying to find an answer and you have it! Thank you very much.

2 Likes

You’re a champion, mate!

This time, rather than installing the font from the zip, for assurance I UNzipped it first, and then used your suggestion (“Install For All Users”) which I didn’t even know was a thing.

Thanks man! I was getting REALLY pissed, esp since the font showed up in literally EVERYTHING ELSE. But noooooooooooooooooooo, not Blender, it’s extra special…

1 Like

The only solution that worked! <3
I have created this account to thank you. So, thank you Daniel.

1 Like

Literally made an account to say THANK YOU! I thought I was going insane…worked instantly!