Can't fix bad shading

Hello how can i fix this bad shading on my model?
The model i’m trying to do is based on an autocad dxf 2d file.

Her is the geometry of the model

I already enable auto-smooth and shade smooth. I also tried harden than normals on the bevel settings but it make things looks worst. Hope someone can help me.

Have you tried recalculating your normals?

Hello this because your mesh ist always triangulated
try selecting the face and split it with pressing the key Y or shade the selection flat

I don’t get what pressing Y does but it worked. Normals was already good

Go to Edit then Mesh then Split then Selection(Y)