Can't Go Into Edit Mode

Default Tab won’t enter Edit mode on mesh.

Here’s my keyboard CONFIG FILE

I’ve tried comparing it with factory settings where it works. To no avail.

Anyway thanks.

Have you a mesh object selected

Supply a blend file

356 kmi =‘object.mode_set’, ‘TAB’, ‘PRESS’)
357 kmi_props_setattr(, ‘mode’, ‘OBJECT’)
358 kmi_props_setattr(, ‘toggle’, True)

Try changing mode to EDIT

works. thanks much, sorry for post.

You should try and edit your user prefs like that:

in “Input -> 3D View -> Object Non-Modal” find the ‘Set Object Mode’ entry (there are several, look for the right one) and restore it by clicking the left-oriented arrow icon on its top right;
after that it should look like that:

If you have a X icon instead of the arrow one, or the issue still persists after the change than you could have some other conflicting assignment of the Tab key, so type ‘Tab on the search’ field on top, select ‘Key-Binding’ on the related menu, and look for that.

I’m sorry for my bad english, hope you can understand even so.


I had this problem for a long time, and know many others that have too. A reply by
DichotomyMatt saved the day. He notes that when you import an OBJ file, it is selected, but is not the active selected object (he doesn’t know why, and neither do I). Right clicking makes the object the active selected object and the mode control, which formerly listed only the object mode, now has all options. Like most people, I am not used to right clicking to select. This can be changed
in the preferences.