can't load images anymore: strange bug?

I can’t load any image into blender’s texture-panel or uv-editor (jpg, png, tga, permissions checked).
So i opened a file with an allready existing image-texture, deleted all meshes and images, saved with ctrl-U, but then, no image can be loaded. I deleted .blend to begin with a clear new file written by blender itself, but the problem is still alive, even after a new install via synaptic.
I’m running on Ubuntu Dapper i386. Because i also have Dapper AMD64 i made sure to use only files created under i386, so it can’t by a problem from the architecture.

I don’t have any idea where this problem suddently came from and what to do now:(…

Many thanx in every kind of advance!

Edit: i figured out, that i only can load images, if an image-texture allready exist. Then i can laod new images, but not from a totaly clean blend-file
Edit2: after reboot, it works again, hope it wont change…
Edit3::(, blender started again: same images cant get loaded, i’m not amused
Edit4: it’s only on linux, xp works fine.

hav you tried to start blender from the console?
maybe you can get a hint from there.
Or you can try strace

no outputs in console.

some thougts:

  • last days, a lot of updates for Dapper were done
  • 2 days ago, i compiled yafray (otherwise it doesn’t work correctly under Dapper) with newest cvs, there was a new dependecy, some jpg-related library, could there be a conflict with blender (i don’t really believe that) ?

no output? …strange…
Im running dapper too (32 bit version), no problems so far.
all updates taken like you. But I have installed yafray via apt-get
Maybe you give strace a try :slight_smile:

i get this after a simple start:
[email protected]:~/scripts$ blender
Using Python version 2.4
Unable to load: libtiff.
Try setting the BF_TIFF_LIB environment variable if you want this support.
Example: setenv BF_TIFF_LIB /usr/lib/libtiff.so

But that is only a missing library… nothing special. hm no idea so far what you can do :frowning:

libtiff-error comes since Breezy, but if i’m told right, it’s not really a missing library, just a silly console-output without any sense (hit me if i’m wrong), but blender was allways working fine.

yafray-compilation could really be a reason.
But didn’t you ever had any artifacts when rendering with yafray? A lot of people (Ubuntu and other distros) suffered from this problem and only compiling yafray solved this (i post related threads, if needed).
Subsurfed suzanne showed some small black artifacts, somethimes bigger parts of meshes had ugly black or white spots.

solved (i hope:rolleyes:):

i deleted my three different blender-installations: standard, cvs-compilation and RC3-binary. Maybe there is a problem, when they use the same .blend-file. now it seams to work (untill:o…).

I spent over a day trying to locate this solution. I will menition I have the AMD64 running 64-bit ubuntu Drake. Over on the ubuntu forums, the distro people after Drake and the distro before Drake told me they didn’t have this problem. I post this for anyone that is looking for the same answer.

With Linux, it is important to know you can start Blender with the Menu Applications>>>Graphics>>>Blender3D modeller – or you can start it with a terminal. A menu in Linux is really a shortcut working a non-windowed terminal. In Blender we want the terminal for two reasons. We can script Python and if Blender has an error, the reason for the error will be routed to the terminal for output.

To open Blender in a Terminal, open a terminal window and type blender at the prompt and a return. Blender will open and cover the terminal window. Depending on your distro of Linux, you can click buttons on the bottom menu bar or you can CTRL+alt+LeftArrow to switch to the terminal window.

[email protected]:~$ blender
Using Python version 2.4
Unable to load: libtiff.
Try setting the BF_TIFF_LIB environment variable if you want this support.
Example: setenv BF_TIFF_LIB /usr/lib/libtiff.so

I soon discovered I could not import a tiff picture or any mesh models that had tiff graphics.

This library, libtiff, has posed a problem to others. Suggestions include setting the PYTHONPATH. Python 2.4 probably does not need the PYTHONPATH set. Try this first. In a fresh terminal, at the prompt, [email protected]:~ locate libtiff and a return. You will get several lines. Look for /usr/lib/libtiff.so.4 or …/libtiff.so.4.1.4. Something like that. The .so is a symlink and the numbers following will have been appended as a newer link if the software needs the same navigation to the library for the tiff processing.

But, you still have the error. Internally to Blender we do not know if the application wants the 32-bit or the 64-bit library or whatever. We just know we want a libtiff library. In my case, I used a package installer to look for libtiff. Using the search in the installer did indeed find several libtiff packages. I chose the package for libtiff4-dev with the -dev being the important part. This means it is the code that makes the library. Often the -dev has a lot more code.

Using the package install, all the pieces to that library knew where to install into Linux. Next time I ran Blender from a fresh terminal, without rebooting, I had:

[email protected]:~$ blender
Using Python version 2.4

Python is working, the tiff images can come in, and mesh model with tiff graphics can import. Now, if it will just stay that way.