Cant open .hdr files - no permission


I dont know why but blender wont let me open .hdr files.

The weird thing is that I can open.exr files which are in the same folder.

Why I can open .exr files only? That makes no sense.
I can run blender as admin and it works again but that was never necessary and I want it to work like before.

The major changes on my system last months:

  • Added a new SSD ( D:\ ) where I put all my Blender Files like Textures and saves etc.( Blender still
    installed on C:\ )

  • I upgraded to Win 10 Pro ( via “change Product Key” )

The error message says:

Permission denied

And you have looked what permission are set on the files and on the folder ? And your user account has the permission to read acess and read them… ?

Maybe it’s just because of D:\… an not …user/data… (i’m not on windows here)

Can you open the hdr’s in another application than Blender?
Were the files linked to another user by any chance?

If not, try to ‘reclaim’ the files by resetting the security settings on the new drive or folders for your user account.
RMB on the drive or folder, go to Properties and go into the Security tab. Have a look there if your user group has enough rights.

But it’s an odd problem, never heard of this before :wink:

I tried Affinity Photo and here I have the same Problem


I ticked Full control now for “Benutzer”. Didnt work or what do I have to do now?


And if I Enable inheritance I can use this file again.

How can I do this for the whole folder? I dont know where to find this option.

EDIT: Ok got it now with this guide:

I hope I didnt break the permission settings now.

Good to see we were on the right track! :slight_smile:
You didn’t break anything, don’t worry.

It’s best to set your permissions on the drive itself, and then do the ‘inheritance’ thing again for all folders and files.
That way everything on the drive will work as expected. Just a ‘to be sure’ step :wink:

It seems your working user account didn’t get the proper rights to the new drive after installation.

I had the same problem for other files again and the best solution is to copy the file or folder and delete the old one.

You can read this article:

You must give permission to this folder/drive, and sub-folders and files, not just the driver permission.