Can't reset rotations

Hello, so I recently opened blender on my laptop again and I’m not able to reset rotations on literally anything with ALT + R, I can reset scale and position just fine but rotation doesn’t work so I have to manually edit the values back to 0 which gets annoying real fast. Any ideas?

Are you using an Nvidia card/drivers? I just tried the Alt+R shortcut in Blender and the shortcut seems to have been taken over by the Nvidia Performance Overlay (which pops up top right of my screen).

To fix it I had to press Alt+Z which opens the Geoforce Experience overlay… then into the wee cog for settings and finally into the Keyboard Shortcuts where I changed it to Ctrl+Alt+Shift+R.

After than Alt+R works properly in Blender.

I’m not unfortunately, this laptop doesn’t have a nvidia card so I don’t think that would even be possible.

and is Alt+R still shown as the shortcut when you look at the menu here

Does using that menu sequence clear rotation?

I wonder if it’s a vaguely similar problem though? Some other program has “stolen” the shortcut?

Yeah it does work from that menu. That’s probably what it is, that some other program has stolen it, but nothing happens when I press ALT + R so I’m not sure what it could be.

I suppose as a kind of workaround you could add Object>Clear>Rotation to your Quick Favourites if you use it often enough.

1 Like

Could you change to Scripting Workspace and press the shortut there in the 3d view. Is an entry created in the list of commands at the lower left? Maybe you must have an object selected.

Alternatively make a screenshot of your activated plugins and testwise deactivate all of them

And did you have a look at preferences keymap and search for the missing shortcut?

Just checked the scripting workspace, it does not show up as an entry, all other clear shortcuts do though. And ALT + R is present in the keymap.

Also might be worth mentioning that I have reinstalled Blender once to see if it would solve it with no luck. Probably because the issue is kept within my settings that got transferred over to the new install.

And no other entry came instead with ALT+R ?
And are there other entries existing for ALT+R in the keymap?

Nope, nothing else came up. And there’s quite a lot but nothing that should overwrite it in the 3D view from what I can see.

Yeah all those shortcuts are exactly the same here. Thats indeed rather strange. :thinking:

If you post another screenshot of clear rotation keymap entry unfolded we could crosscheck that.
Otherwise I’d really recomment deactivating all plugins for testing. If it works with having them deactivated you might reactivate them one by one to find the cause.

Finally you could try simply adding the broken entry once more manually and see if that helps or testwise change it to another key

The only self added plugin I have on my laptop is Node Wrangler, everything else is Blender default so I’d be surprised if it was one of those. I’ll have a look at it anyways
Adding the entry bpy.ops.pose.rot_clear() manually reset its position like it would but the shortcut still doesn’t do anything. Changing it to another key does make it function again.
image

Then its very likely not blenders fault. The shortcut may be consumed before it reaches blender. If you are under windows you might have to check your trayicons for something with that shortcut.

Yeah must be at this point, disabling all addons does nothing to help the problem. Thanks for the help!

Good luck!

1 Like