Can't see background

Hello everybody

I’m experimenting with a scene where I started by importing a file generated with fspy: camera, background image, etc…
I added a cube and a plane with the shadow catcher turned on and the shadow works.
But I don’t understand why when I render the background image is not shown….


I checked all the settings and there doesn’t seem to be anything wrong… any advice?

Thank you!

Camera background images don’t show up in the render, you can add a plane with that image as a texture or set that image in the World settings of the shader editor

1 Like

thank you for your answer, I made a step forward but not solved yet (due to my “rookiness”… :slight_smile: )
If I add a plane is there a way to allign and to light it exactly in the same way as the background?
I tried also with the world setting, in this way:


but if I use the “Image texture node” I don’t see anything again, and If I use the “environment texture node” I see the image but not alligned and rounded (like an hdri)
Can you please give me another little help?

I think this will work, at the very end of the answer he mentions to use the “window” texture coordinates in the background shader.

1 Like

thankyou everybody! :slight_smile: