Can't see edgelines on separate selection?

Hello, I’m new to blender and I’m following a tutorial online that required me to highlight some vertices and seperate that selection using “P”. I did so and it seperated them. However, now I can’t seem to see any of the vertices, edges or faces on the seperate selection. I’m sure there is an easy solution to get the lines back up, but I cannot figure it out nor can I find any help with it. Any comments would be appreciated. Thanks!


Go into edit mode to see the mesh or to show the wires in object mode enable Wire display and All Edges option


From the looks of the picture, you need to tab out of edit mode, select the other piece and enter edit mode again.
In that picture you have two selections but you can only be in 1 edit mode at a time.

“3d view > properties > display > all edges” seems to be missing in 2.66?

It’s now in Object tab of the Properties window (not N panel, the big properties window with tabs).

EDIT: right under Transparency if you look at Richard’s screenshot.

understood, thanks.