can't seem to get rid of these black spots
anyone have an idea?
using 1.3m photons
scene has 6 pointlights
the walls have no tex, pretty much the default blender material, with nearly no spec

Same image, no textures

with 2.3mill

Recalc normals?

nope, the normals are correct, and the walls are only single faces anyways.

It seems to happen to objects without textures (or maybe all objects, though the textures hide it??)

for example, the light, and the base and the walls

Please? someone? anyone? I am completely stuck on this,
tried increasing the photon count to 2.3mil to no avail.
tried changing the gridsize, the cache size, search…
nothing seems to do anything.

If anyone could provide any insight, would be much appreciated.

i have encountered this before, though i am not sure under what conditions,…i just remember that something about my settings was wrong. if you put up the blend i would be happy to have a look at it.
<edit> oh, hey,…another possibility: try remove doubles.

in EDIT (‘mesh’ section) buttons, try leaving pressed “No V.Normals Flip” , that one bellow double sided.

I experienced black spots(small areas) in textured models (aslo shown in just solid) Then I unchecked double sided, but did not work. Then I pressed the button I mentioned, and the problem went away. Even leaving after that the button unpressed. The problem had gone…

There is a thread at regading this situation. Go there and take a look on how to tune your photons to gtet rid of this siutation.

I have no clue how to do it, but I know the enswer is there.


The weird thing is, If I remove all the textures off the floor, mat and table, the walls don’t do it anymore??

this is really odd.

The only thing I can think of is because the textures are detailed, the renderer shoots more photons at them.

I have looked on the yafray forum, and studied the docco heaps.
just nothing seems to work.

I’ll try the vertex normal flipping thing.
Otherwise, I’ll host the blend somewhere.

Thanks people.

Well, for the majority of it, it ended up being my scene was scaled too large.

I still have a few artifacts on the walls though, I can’t seem to get rid of.

If anyone could have a look at it, I’ll zip and send the XML file.

I just have no-where to host it.

Thanks for all your responces.

Well, I still can’t seem to get rid of the artifacts,
If someone could have a look at the XML file, I zipped it (for reasons other than size)
and a render of the artifacts

Gah, forgot to check the link before I posted it.

Please… anyone… i’m completely stuck.

and the blend file also

for anyone’s information, the new version of yafray solves this problem.