Can't seem to install Blender (OSX 10.3 panther)

Hi folks, this is a weird one,

I downloaded the following apps/utilities that are apparently necessary to run Blender.

-TclTkAqua-8.4.10.dmg
-Universal-MacPython-2.4.3-2006-04-07.dmg
-blender-2.42a-OSX-10.3-py2.4-powerpc.dmg
all of which are supposed to be compatible with my OS (OSX 10.3 panther)

and installed them on my boot disk but alas clicking on the Blender Icon just makes it appear in the dock for a second and disappear again, I’m at my wits end :mad:

I’d really like to give Blender a go (dabbled in C4D a few years back)

The thing is this Python game seems a bit of a code/terminal/console affair and I’m not a script person by any stretch of the imagination…which is a shame.

Any help appreciated.

Marco

Germany
:smiley:

just download the version of blender compiled for python 2.3. I’m running OS X 10.3.9 and couldn’t be bothered with upgrading python (tried once or twice, didn’t seem to work, and reverted). py2.3 is the default on Panther, so just go ahead and use it. I’ve never run into any limitations. I’m sure someone else out there knows how to properly upgrade to 2.4, but not me :slight_smile:

Thanks, will do, any idea on which
install disk it’s sitting??

Marco :slight_smile:

OK this is starting to be a major [email protected]@ck, I downloaded a file called
MacPython-OSX-2.3-1.dmg, downloaded it 6ish Megs, then I downloaded a file called ,MacPython-OSX-2.3-2.dmg, 940 kb, which is supposed to be a patch to make it work on Panther and I installed a dmg called ‘blender-2.42a-OSX-10.3-py2.3-powerpc.dmg’, I’ve tried all possible combinations of dragging icons on other icons, opening apps with other apps, just what does Python want me to do?? Or Blender for that matter, all the info file is giveing me amounts to so much esoteric codespeak, I’m not up to this.

thanks,

Marco :slight_smile:

python should have been already installed by default on your system. Open up Terminal (applications>Utilities) and type python <enter> that brings up the python interpreter and tells you what version is running. hit CTRL-D to quit. Most likely you can uninstall those other python DMGs you downloaded, and remove the blender for py2.4 if you haven’t already. (I’m assuming you don’t have an intel Mac since you’re running Panther. So the version of blender that you downloaded should be a good one.)

Then open up the console (also in utilities) and try starting Blender. What sort of errors do you get? Alternatively, you could start blender from the command line with debugging info turned on…

iMac:/Applications/Blender 2.42/blender.app/Contents/MacOS $ ./blender -d
guessing './blender' == '/Applications/Blender 2.42/blender.app/Contents/MacOS/./blender'
Compiled with Python version 2.3.
Checking for installed Python... got it!

this will, or should, start blender with a maximized window, going under the dock. OS X has an open GL issue with overlapping GL items (blender’s interface is all GL), so any overlapping GL items, including the dock, will be super slow feeling. So resize your window.

If you need to completely uninstall all traces of a program (dragging the .app file to the trash isn’t complete), I recommend OSXPM (osxgnu.org).

Hope this helps! Good luck, and welcome to Blender.

Hmmm, re-reading what you’d written, my suggestion may not have helped any so I’ve removed it for now.

Thanks dschnell!
I’ll be in touch about those error msgs, chances are though (buckle up) it was me being on OSX 10.3 instead of 10.3.9! paints the 9 red

Can anyone confirm this is an update issue?

Marco :slight_smile:

As far as I can recall, 10.3.9 is the recommended minimum (and it’s a free update from 10.3.x).

It did seem strange you were having so much trouble. Generally speaking, the main, non-bug, problem most Mac users encounter is installing Blender for the wrong version of Python.

What the pancake and maple syrup …

It was indeed a system upgrade :eek:
Seems to work fine as far as I can tell, it feels very deep, I’m in for a steep learning curve i think…

Thanks guys, thanks for the welcome!

Marco :slight_smile:

Welcome aboard :slight_smile: