Can't select bone in Weight Paint

Hello!
My first post on these forums :stuck_out_tongue:

Anyway, I’m a Blender noob and still trying to learn the whole thing.

So, I recently started with animation, I got the mesh + Armature.

But then, when I try to weight paint the thing, I can’t select a bone like everyone in the tutorial videos do, it selects the whole armature instead!

I have done everything: Name the bones, name the armature, insert modifier on the mesh…

But when I try to weight paint, I always get stuck.

I tried to make vertex groups manually but it animated pretty weird then (only a body part moving and not the whole mesh)

Any help would be appreciated! If you need more info, please ask :slight_smile:

Select the armature, go into pose mode then select the mesh and go into weight paint mode. You should then be able to select different bones and weightpaint.

3 Likes

Works now! Thanks a lot! :slight_smile:

Sorry to hijack this thread, but my search came up with this question, and I have a similar problem, but I still cannot select a bone in weight painting. I selected the armature>>pose mode>>selected mesh>>weight paint mode. Still cannot select bones. I’m using 2.54 r32398 for OS X. Any ideas?
thanks

Well on a hunch, I believe I figured it out. I’m one of the few out there who started learning blender with “left select”. When I returned the program to “right select” it worked. Is this something that should be reported, or should I just hide in shame as one of those “left select” users?

This is an old thread, but it was still high in the search results when I was looking for a solution to the same problem. A friend just showed me a much better way to select a different bone while weight painting:

  1. Enter Pose Mode
  2. Select a bone in the armature
  3. Shift-select the mesh
  4. Enter Weight Paint Mode

Now you can hold control and click on a new bone to select it.

2 Likes

Still doesn’t work for me. I have blender configured for left click to select.

Duh, I take that back. Now it started working. Dunno why it didn’t before.

For me again it doesn’t work that way. I’m normally using left click. Right click will do the trick, but I think this really is a problem in blender at the moment.

The problem here is that both Select and Weight Paint are set to the same key - Left Mouse. I’ve remapped Weight Paint to use Right Mouse button and now both functions work just fine. You can remap the button by going to File -> User Preferences… -> Input, entering “Weight Paint” into the search bar and remapping that function to something else. Otherwise I don’t see how blender could differentiate between these contradicting inputs.

For those who chose different settings and simply right click does not work, try CTRL + LEFT CLICK.
or SHIFT + LEFT CLICK for multiple Bones.

That works with my settings.

1 Like

Fresh to Blender. Encountered same problem. None of the previous suggestions worked. This suggestion of SHIFT+LEFT CLICK was the only thing that worked, and it worked beautifully. I don’t understand why though. I’ll probably figure it out with experience.

This cracked it for me, using 2.79b on an old Mac. Thanks.

Oh God. Damn. I’ve been trying to do this for two hours. Trying to select select with Shift+LMB, select with Shifrt+RMB. Watched videos on YouTube and read forums uselessly. The problem was I haven’t gone to the Pose mode. Thank you.

You don’t have to. In Object Mode select the armature, then the Mesh and enter Weight Paint.

Ack all of these isnt working for me… ;-;
i tried to set the armature in pose mode and either shift click or click the mesh body after but that didnt work it didnt allow me to click the mesh after in pose mode

I also tried click the armature first and shift click the mesh and then get into weight paint mode but that didnt work either the armature just shows up the deep orange

I found a 2.8 tutorial that says to shift click the bones and start painting but HHH I cant even shift click the bones I can only use ctrl to deselect with no way to select again

what Am I doing wrong here AAA

I also applied all the rotations if that was a problem

Is it cuz my UV map? I joined seperate objects with already coloured UV maps onto one but idk if that it

The only other thing can think of is my vertex groups I followed this tutorial


And I have a vertex group of my bones if that was a problem?

I have the same problem! I have been trying to do this for hours and still don’t know what to do!

I just came up against this today, again. Looks like the new method is to select the mesh in Object Mode, switch to Weight Paint mode, then hold Shift and right-click anywhere on the mesh itself (don’t try to click the bone). Then you’ll get a menu that shows all the bones that are currently affecting that part of the mesh, and you can choose which one you want to select.

i also found a way over this, there is an option that you can disable to let you leave each object in one mode, can’t exactly remember which menu because i don’t have blender open right now. Then you can just do the older method and shift+right click the bone itself.

For anyone still stuck, go into object mode, click and highlight your amature then shift click your mesh ( the order is important ) so now you should have both selected. Now go into weight paint mode and you should be able to select any bone to weight paint. Hope that helps

1 Like