Can't select bones in weight paint mode - blender 2.8

I posted this in the blender 2.8 thread but have not gotten any reply. Hopefully someone here will be able to.

I’ve been trying to weight paint my character in 2.8 but can’t find a solution to painting vertex groups by selecting bones.

I know you can shift select for different vertex group, but I want to be able to select bones which then highlights the vertex group.

I did find another post indicating that “lock object modes” needs to be unchecked - It is.

I also found a short video saying you need to first select the armature, then the mesh, then enter weight paint mode, but I am still not able to select different vertex groups by bones.

Anyone have an idea how to accomplish this?

5 Likes

Yeah the new 2.8 is not intuitive at all. But go to object mode. Select your armature, shift select your mesh. Go to weight paint mode. Shift select your bone and it should work.

I hate they introduced another selection method for skinning.

8 Likes

Yea, this is what I have been trying to do and still does not work.
Below is what I get.
The bones remain orange and the only I can select are the verts - which appears to need to be selected in order to weight paint.

2 Likes

Your in edit mode. Follow first post I did.

I did follow the steps you gave and i am definitely in weight paint mode. See image below.

If the Verts are not selected I can’t paint

aa

The only way I can paint is if the verts are selected and if i’m selecting verts I can’t select the bones

This is the build I have on my work machine,
image

My home machine is a build I downloaded yesterday and does the same thing.
could this be something broken during development?

You have vertex selection mode on. You couldn’t select bones in 2.79 with that on either. If you turn it off you can select bones.

OK, so I got it to work, but not exactly the way you mentioned.
here is what I did.
1-select bones and enter Pose mode.
2-go to edit and check mark the ‘lock object nodes’
3-exit pose mode and go back to object mode

4-Keep the armature selected then shift select the mesh
5-then go into weight paint mode.

6-in weight paint mode the bones will appear to be in pose mode, though you can’t actually pose them, but I was able to active vertex groups by selecting the bones.

With this method I do not need to SHIFT select the bone. I can simply pick each bone and the vertex groups would become active.

If I tried to select the armature in object mode then shift select the mesh then enter weight paint without steps 1-3 it did not work. Instead shift select would switch me between the mesh’s weight paint mode and the armature’s object mode.

Oh, and turning off vertex select mode worked too.

Thanks for the help

5 Likes

Thanks everyone, I just spent an hour trying to find out why I couldn’t select my armature bones in weight paint the usual way ( ObjectMode: Select armature + shift select Mesh ).
Then it turns out , the Toggle select faces was on , (at the usual upper left corner ) .
what a relief…

2 Likes

Here’s what I didn’t do: “Shift select your bone”
Thanks!!

I’ve been having this problem myself following the auto-weights tutorials, and I’ve finally figured out the problem I was having. Can’t say that the issue is the same for you guys but this is my fix to this problem.

When you go to parent with automatic weights, make ASOLUTELY CERTAIN that your active object is the armature and NOT THE MESH.
I don’t understand what’s happening in the background, but here’s my guess. When you use parenting options in the 3d view, it assumes that you are making everything you have selected as children to the active object. If the mesh is the active object, since the mesh itself doesn’t move without animation, the child armature has no reference to effect its own children. Making sure the armature is the parent of the mesh allows the mesh to to give the parent armature data to affect.

So again, make sure that the armature is the parent of the mesh, and not the other way around.

1 Like

Solved (at least for me): Once you have selected your Armature then shift selected your mesh and entered weight paint mode, make sure you are NOT in Face or Vert select mode. If you are in either one of these, just click on the icon, like the face select icon, to toggle it OFF. If neither are selected you should now be able to select bones with ‘Ctrl’ + ‘Left Click’.

This is unintuitive, would be great if they added a bone select icon to provide proper feedback.

guys. please check my video. I have solved this ploblem all going back to normal as weight paint mode should work :slight_smile:
Blender 2.8 _ Cant select bone in weight paint mode FIXED!!!
i hope it will help you out :slight_smile:

1 Like

None of this has worked for me. looks like Bones are boned for a lot of people

Thank you everybody for this thread. It helped me last time - 2 weeks ago.
Today, I failed, no matter what.

The solution was: I hadn’t parented the mesh to the armature yet.

Complex blend. I just wanted to get one small change done and get out of there. Leads to attention deficit like this.

Dear scrolling frustrated user:

Make sure your mesh is parented to your armature.

Glad to help. :wink:

life saver! i was like dying trying to figure it out but turns out i aws parenting the bones to the mesh omg

This works for me, but when I use shift + select, it leaves the last bone selected, and both will be selected, and I have to shift + select the last bone that was selected to unselect it. To just select a new bone and deselect the old bone, you can use CTRL + select. I’m in 2.83.4.

This literally took me a week to figure out. Thank you so much for posting the steps!

I wonder why any programmer in their right mind would ever make a feature as necessary as this so difficult to use?

2 Likes