Can't select bones in weight paint mode

Hi everyone,

Like many before me, I’ve been following a tutorial on rigging when I got stuck at the weight painting phase.

My problem is that I can’t select the individual bones in weight paint mode, instead the entire skeleton is selected. Additionally, I’m not able to paint anything. All I can do is select or deselect the skeleton.

I read a number of threads on similar issues and the replies was pretty much always that you need to first select the bones, then go to pose mode, then select the mesh, which brings you back to object mode and then select weight paint.

This does not do anything for me though, it’s absolutely no different from going straight to weight paint mode.

I’m using a standard installation of Blender version 2.68.

Thank you

You need to put the rig in Pose Mode before you put the mesh in Weight Paint Mode.

Did you read all of my post?
As far as I know, I already did that and it didn’t make any difference.

When you say put the rig in pose mode, you just mean select the rig and switch to pose mode, right?

Alright, so I redid the rigging again in a sort of troubleshoot state of mind, minimizing the factors, and it now works.

What I did differently was creating the bones individually, so no copying, and I joined (Ctrl+J) the mesh parts to get a single mesh.
Along with that, I followed yours and others’ instructions by selecting the skeleton in Object Mode, switching to Pose Mode and selecting ALL bones before selecting the (now single) mesh while in Pose Mode and then switching to Weight Paint Mode.

Now, I don’t know which factor caused this issue, but I will say that there are a few aspects of Blender’s rigging tools that can be worked on. If nothing else, it’s a confusing process that I know throws off many new users, more so than other basic aspects of Blender and it does so unnecessarily.

Thanks for your help

Select the armature
Go into Pose Mode
Select the model
Go into Weight paint mode
Select whatever bone you want to weight
Quite straightforward

switching to Pose Mode and selecting ALL bones before selecting the (now single) mesh while in Pose Mode and then switching to Weight Paint Mode.
Just tried and I don’t need to select all the bones in pose mode

Thats the symptom of a mesh not having an armature modifier set for the armature via Ctrl-P or Properties > Modifiers. Did you happen to notice if the armature had jumped back into object mode when you selected it? Probably so by your description “instead the entire skeleton is selected”.

…it’s a confusing process that I know throws off many new users, more so than other basic aspects of Blender and it does so unnecessarily.

There is nothing basic about rigging/skinning. Missing one little step in a Blender tutorial is more often than not a complete show-stopper. Poorly explained features and settings by many tutorial authors also make it difficult for new users to troubleshoot problems. You may as well get used to the fact that when first starting out you will often have to step through a tutorial multiple times before you get it right.

Welcome to BA Forums.


It’s apparently not very straightforward as I already did this, I even stated that in the OP.
After trying this several times, it still didn’t work right, so there is definitely more to it than that.

I’m sure that I did set the parent, as I remember selecting automatic weights on the menu it gave me. Is that what you mean?

And thank you Larry.

I’m not a stranger to learning new pieces of software, so I know that you will get stuck a lot and that you will likely have a hard time getting used to how things work. However, I still think that having this many users strand on a single, very specific issue is something worth a little focus. If you look at how many hits there are on this and similar issue, then you gotta admit that something isn’t the way it should be.

I’m just giving feedback, it’s not a complaint or me trying to criticize Blender because I don’t understand it. I really enjoy Blender and I appreciate that it’s offered for free, that’s why I choose to comment on something that I think needs to be optimized.

Thank you for your help.

The procedure is simple and straightforward, but it’s not working for you. That means there’s something wrong with your particular example, not with the procedure. Something is messed up in your file, or you’re doing something wrong. What needs to be optimized here is your model. Post your .blend file to and share the link here and we’ll figure out what’s wrong.

Like the majority of everyone who posted threads about this issue, I fixed my model by starting over, not by following your instructions, so obviously something along the way is not simple and straightforward.

Here is the latest .blend I saved before I started over:

Sorry it took me so long to get back to you; I’ve been away on vacation.

I have no trouble selecting bones with meshes in weight paint mode on the model you linked to. There doesn’t seem to be any problem at all. The character is made of multiple mesh objects (I’m not sure why you did it this way), so you’ll need to put each one in Weight Paint Mode individually once the armature is in Pose Mode, but yes, it is exactly as straightforward as Richard and I described.

There is no need for you to start over. The only thing to be solved by starting from scratch as you describe is to correct mistakes that you didn’t notice the first time around. It’s not as if performing the exact same steps magically produces different results just because you do them a second time. If the results are different, it’s because your actions were different. But in this case, there is no need for starting over or doing anything differently because this model works fine. Put the armature in Pose Mode, then put each mesh object into Weight Paint Mode. You’ll only be able to work on one mesh object’s weights at a time, but that would be solved by joining the objects. As previously mentioned, I don’t see any good reason why you should make the body out of multiple objects like this in the first place. You can have disconnected mesh pieces within a single object.

Actually I ran into this problem as well, and I know for a fact that it didn’t have anything to do with my own work flow. I was doing the same thing I always do. The difference? I hadn’t weight painted since I had updated my installation to the most recent version. So I uninstalled blender, and reinstalled it and it worked. So it could very well be a faulty installation because I haven’t had any problems since.

Can’t select bones in weight paint mode "
I’m a noob on 2.69 on a Windows 7 machine and I’m having this problem as well. It worked initially and then quit. Now whenever I try to select a bone in weight paint, it puts me back into Object view with the entire armature selected. I tried everything suggested here before even finding this forum. The armature modifier is assigned to the mesh and it doesn’t matter what is or isn’t selected in pose mode.

The only work around I found was clicking the auto assign weight paint based on bones (or whatever it actually says). Then you can select the vertex groups by bone name in another window (I forget the actual name of the window, sorry) and paint them MORE. I’m not sure if you can do anything else because autoassign worked for what I was doing.

I stumbled upon a problem like this which made me bite the keyboard… Just check if “face selection masking for painting” is selected. You can find it in the menue-bar, it’s the little icon that looks like a box with one side painted in checkers. It actually is connected to the mesh-selection in edit-mode, i.e. you can only paint weights on vertices that are selected.

It has its use, as in this mode parts of the geometry hidden in edit-mode are hidden as well. It helps a lot in complex meshes, where parts get in the way of painting other parts. Just remember you can only paint what you have selected (press a to select/deselect everything, just like in edit-mode). The problem is that you can not select bones any more in this mode (not sure why, it doesn’t really make sense).

To get back to normal weightpainting just turn it off.

^ Normal weight-painting

^ Face-selection-masking turned on, no vertex selected -> you can’t paint anywhere, you can’t select any bones, user starts using strong language

^ all (visible) vertices selected, except for the ugly lines you can weight-paint normally