Cant Texture paint in 3d view anymore

Hey guys ive been doing some texture splatting and it was working fine till (who knows when) the texture paint tool stopped working in the 3d view. I tried reselecting the object, but nothing works :(. I can however paint the texture in the UV window, but it just isnt the same feeling as painting in 3d view directly :no:. Could i have changed some settings? Thankyou!

it works perfectly, you must have a lame build.

make sure you didn’t press F by mistake, pressing F turns on the Mask which means you can only paint on selected faces in the viewport

the other reason it will only paint in the viewport over the original UV coordinates - so that’s something to watch out for if you have any kind of tiling or any portion of your UV not actually sitting within the bounds of the image

Face paint is not selected, and i cant paint in the viewport, only the UV window. Nothing will paint anymore, and it is properly uved. And no cyborg, im using the newest offical build (2.48a)

well then next check your brush settings

oh yeah and if nothing else works, make a viewport render by pressing the icon on the viewport border

IF THAT doesn’t work, try toggling your map-to stencil adn no RGB settings a couple of times

brush settings are perfect.
tried both of your recommendations and nothing works.
And btw, my stencil IS working and IS showing up, i just cant “edit” it in the 3d viewport.

Hi, it sounds like you are having the same problem I was. Try this: select your object, go into edit mode. Select ALL faces-now in the UV window select the stencil you want to paint on. Go back into object mode then texture paint mode…see if it works.

1 Like

Same thing happened to me. My problem was caused by the stencil size and the fact that I had the GL Texture clamp set at 512. Anything above that didn’t work. Once I set GL Texture Clamp to off, it worked.

Hey spiderbyte, I just figured it out. You are probably trying to paint the inside of your object. Try flipping the normals. Hope that helps, sorry for the delay.

2 Likes

12 years ago m8 :stuck_out_tongue:

1 Like

Thanks bro! İts really helped me out on blender 3.0 alpha even after 12 years XDDD

tHANKS FOR HELP, YOU HIT THE RIGHT POINT, INDID THE NORMALS WERE FLIPPED