Caustics on Wine Glass

This doesn’t show any caustics. It there a setting to increase caustics. I have watched several videos that I need a plug in like Appleseed or LuxCoreRender. Does Blender have one as well?

wine

Without knowing your rendering settings or the version of Blender you’re using, I would just say to make sure that both the Reflective and Refractive caustics options are enabled in your render settings (look under the sampling panel).

Additionally, you want more rays to traverse through your objects and collect/concentrate on your plane. This can be tweaked by raising the number of minimum bounces in your integrator settings (still under the sampling panel).

Screenshots of your render settings could be helpful in helping you further.

Yes it does. See those red dots in the shadow? That would be caustics, as glass/refraction shaders does not allow light to penetrate without it. Unfortunately you need insane amounts of samples to produce good looking results with a path tracer. Nature of a path tracer that Cycles uses is being “more or less fully random” wrt where it sends its rays, meaning you would be wasting tons of rays that doesn’t contribute significantly.

Other renderers use a different technique helping this out massively. But devs say that implementing this would cause us to loose a lot of other different features that are directly incompatible (such as any light path tricks we use), so they don’t “want to”.

1 Like

There are caustics of a sort, but as others have said… Cycles isn’t the best at them.

I don’t know what setting I need to tweet.

Try render Samples to 10,000 and see how that looks. As people have said, caustics is one of the few things that Cycles is not very good for right now, so people have come up with various cheats to simulate them, calculate them in other programs, etc. Google for “caustics in cycles” gets plenty of hits.

Just download LuxCoreRenderer if caustics are specifically what your looking for… here’s a 6 min render on CPU


causticWine.blend (2.4 MB)

https://luxcorerender.org/download/

Thanks guys. I can’t add-on LuxCore. There is an issue, and I don’t know what it is?

Did you install the VS C++ 2017 Redistributable files? It’s on the download page for LuxCoreRender, the error message is saying that

I’ve been messing around a lot with glass shaders lately, and your right, for truly realistic results you will need to go with Luxcore or Appleseed or similar.

If you did want to stick with cycles, then faking it is the best compromise. i’ve had good results with the shader in the Variety Node pack which can do both dispersion and caustics.

I had this problem a while ago. Asked on the Blender Stack Exchange site. https://blender.stackexchange.com/questions/2558/how-to-illuminate-the-darkness-inside-glass-objects-in-cycles and wchargin wrote an excellent answer https://blender.stackexchange.com/a/2565/606 and it seems to still stand for today. (But then, I haven’t done much of anything involving caustics since then.)

Bottom line: you can get what you want, up to a point, but Cycles might not be the best choice of renderer for high quality caustics.

Well that’s pretty good …