Changing array distance with curve

I am making a rope ladder which is to be animated. I have created cube and added array and curve modifiers to it. I’ve attached Hooks to the start and end points of the curve. Since I have to animate it, I want to be able to manipulate hooks to desired size and I want the array to stretch to the curve accordingly throughout the animation. So how can I achieve this?

Edit: I’ve also tried constant offset in the array modifier.

If you don’t want the number of boards to change as the curve gets longer, set it to fixed count, not fit curve.

If you want them to stretch from one end of the curve to other, enable bounds clamping and stretch on the curve, in properties/object data/shape.

If you don’t want the boards stretching, but only changing position as the curve changes shape, there are a number of different ways to do this. For what you’re demonstrating, I might do this with array->curve->skin modifiers, using only strings of vertices:

Other techniques include running it through non-rendering, face instancing planes, or running it through an armature to kill the stretch.

Thank you so much for the reply. Your last solution works…kind of. I want to dynamically change the array offset with changes in curve length (by hook) while keeping the array count constant which is happening, but after applying the skin modifier and enabling stretch, the cubes doesn’t orient themselves to the curve.

Then another technique you might consider is instancing from planes:

The instanced objects don’t inherit the stretch of the face, only the position and orientation. You can see with the two objects with different curves.

The instancing array should be given a transparent material. The instanced object should be parented to the instancing object.

Thank you very much and sorry for the late reply. This works really well but one hiccup - The instaced object is visible in the viewport at all times. I only want the instancing cubes to be visible and I can’t do that since the materials are linked. I tries moving it to another collecting and disabling it for renders, but all the instanced cubes also gets disabled.

For me, there’s nothing you need to do to prevent the prototype from showing up in renders. It’s hidden automatically:

That’s an Eevee render, but I tested with Cycles too, same thing.

If you’re concerned about the 3D viewport, not the render, just hide the prototype. The instances still show up (for me.)