Changing background color

Hi! I know this has been explained many times. I did follow information on different links before coming here.

I believe I am doing what I read. I added the nodes in the shade editor in order to override the HDR information for the background (I still want the HDR lighting). I turned on transparent within my render settings…still I see no background color:

I am pritty sure this should be really easy, but not working for me :frowning:

Hi, you need to turn off transparent.

Then I see my HDR in my viewport

Why not just do it in the World nodes instead of compositing?

Then go to the world shader and delete the image shader of the hdri.

Cause I do not know how to do that. Now I know, thank you!


I can’t seem to get this to work – which is sad because it’s exactly what I need. Here’s my screenie:

What am I missing? Tnx.
Solved: I had to go back and turn off TRANSPARENT in the Render tab.

Hi ! I believe you have the transparent box active:

Yeah, I figured that out, see the coda.