changing color in the BGE: DONT WORK! (with toonshading script)

(Mico27) #1

hey I got a slight problem, I want to change the colour ( flash red) of my character when he’s hurt (collide by a “beam” property) when “use blender material” is on it do not work, but it work when I DO NOT use “use blender material”, but I NEED “use blender material” because it has to be turned on to show the toonshading. I dunno what to do, if anyone as an idea here’s the .blend file.
http://www.savefile.com/files/1058339

cheers

0 Likes

(OTO) #2

Hello
you must use Col R, G, B, ipo curves!
Select your object, in the IPO window , select ColRGB chanels, put the mouse
cursor above the window, press Alt key and click to insert a control point
Then place them at the desired locations and frames
Ex: Black: RGB :0 White: RGB : 1 Red: R:1 GB:0
When done enter Face Mode select the desired faces/all, enable OBColor button and
press the Copy Draw one.
Now if you have lights in your scene you should enable the “light” button too.
Bye

0 Likes

(Mico27) #3

I did everything you said OTO and it didnt worked, but I think that the toonshader script has something to do with it…

0 Likes

(OTO) #4

Yes, probably the script overlaps the face settings!

0 Likes