Changing emulate 3 mouse button key

when emulate 3 mouse button is checked, blender uses altkey as a replacement for MMB. but using, alt remove some action that normaly use alt key. i was thinking since i’m not using spacebar that often, can i have my spacebar to emulate the MMB instead of alt key. so that way, i can have emulate 3 button mouse checked but still have alt key to do it’s usual things.

I have no idea about other versions, but in 3.0 you have an option to change it to the “super” key.

Yes, this feature is available since version 2.8. Sadly, it does not offer to use the spacebar, as you want to.

i think super key is acceptable, where can i change the prefer key again, i saw in someone post there’s a drop menu under the emulate 3 button mouse, but my preferences doesn’t seem to have one.

Strange, It looks different here:

What exactly isn’t working for you? I’ve been using the emulate three button mouse option since I began using Blender oh so many years ago, and I’ve never once ran into a issue where it conflicts with anything.

my main problem is selecting edge loop, by default to select edge to you use alt+LM. by enabling emulate 3 mouse button i can’t use alt to select edge loops. i know i can change my edge loop shortcut to other key and i should be fine. but if there’s a way to change the emulate key i would prefer to change the emulate key rather than the select edge loop.

You know you can double leftclick to select edge loops, right? It’s what I’ve defaulted to since 2.8.

tbh, i don’t know. i’m new to emulate mouse button, because my mouse is getting old. thankyou for mentioning the double click, i think, i can get myself use to this.