Changing extrapolation to 'cyclic'


I am a user of Blender 2.59.

I would like help regarding F-curves, as I have used several LocRot IPOs and need to repeat the actions of the IPOs. I know in 2.49b, having used it before, that one must use the IPO extend menu and then select Cyclic Extrapolation. However, In 2.59, I have seen no such option. After googling for some answers, I find that I should use F-Curves, and add a Cyclic modifier.

My problem is, when I go to click on the ‘Add Modifier’ button, it is greyed out, and I cannot click the button, even after selecting the desired IPO. Also, is there any way I can select all the IPOs and then add the cyclic modifier to all of them?

Thanks :slight_smile:

Seeing as you are using such an old version of blender I don’t recall if this option was available. In the graph editor under the Channel menu entry there is an option to set the extrapolation mode to cyclic for the selected channels.

Well, I checked as you suggested, and in the Graph Editor:

Channel -> Extrapolation Mode -> Constant Extrapolation
-> Linear Extrapolation

I’m using 2.59. It isn’t all that old.

Don’t understand why the ‘Add Modifier’ button would be greyed out, can you post the .blend file showing this? As to adding the cyclic modifier to all f-curves, in the soon to be outdated 2.62, in the Channel -> Extrapolation menu there are 2 more options you didn’t mention, Make Cyclic (F-Modifier) and Clear Cyclic (F-Modifier) that does add the f-curve modifier to all selected f-curves at once. Since you don’t mention these options with 2.59, you’d have to add the modifier one curve at a time.


Ah ok, thanks for that. Here’s the file
(exorcism beads2.4.blend (1.11 MB))

Checked the file in 2.62 and the add modifier button isn’t greyed out:

And after selecting all the curves for BezierCurve.000Action and using the method I described, all of them have been made cyclic:


Thanks for this, it is much appreciated.