Checker pattern on LookDev/Rendered mode in Viewport

After I updated Blender 2.8 I got checker pattern in the viewport, when transparency is on.

Is there any way to disable it and left transparency on? Or I should turn it on/off manually each time when I want to render an image, if I prefer to work with a solid background in the viewport?

I think 2.79 behaved the same way, so it’s probably going to stay like this for 2.80 final.

But in 2.79 we didn’t have real-time viewport like Eevee which we can use to model things too, so it’s a bad choice to not add the ability to turn-off this checker pattern at least in settings.


I also noticed that today. You can´t even properly see your geo, which is really bad. It might be useful to have this option, but PLEASE I want to be able to switch it off! If anybody knows a solution…?