Circle with a face problem.

In Blender 2.63 I can create a circle with the standard 33 vertices’s and create a face by hitting F, and then I use it to project an image onto, using an image texture, but in 2.62 it doesn’t see that face; nor will it allow me to create one; currently 2.63 crashes on my Ubuntu 12.04 x64, using cheleb/blender-svn repos; I have another machine that this works fine on in 2.63; this machine gets a segment fault error; not sure how to fix it; this is an i7 CPU, whereas the other is a Xeon; but my question is about how to get a circle with a face in 2.62, since it works fine on this machine


You could always extrude, confirm it and then alt-m and choose center.

Wouldn’t that give me Triangles instead of a face?

Which is the same as creating it with Fill checked.

Triangles do not work well as projectors.

This was a fresh install of Ubuntu Studio 12.04, I installed KDE, so maybe its just this machine; I did an upgrade on the other machine; for 11.10 to 12.04, and it has Blender 2.63; I did test this on a Ubuntu Studio 11.10 machine with 2.62, and was unable to create a face with more than 5 vertices’s, so it works great if you want a Pentagon, interesting; it must have been a new feature and I didn’t think twice since it worked from the SVN, till it started crashing on this one machine, just when I have a heavy work load of rendering to do; so I was hopping that someone else knew anything about this feature; I’ll trouble shoot the crash tomorrow.

Thanks for the reply.

With Blender 2.62 you can only triangles and quads. 2.63 introduced BMesh which lets you create faces from any number of vertices (NGon).
As for the crash: start blender from the console with the -d option. Check the Bug tracker (Link in the help menu), if there is something similar reported and report it.

Sorry, I wasn’t quite sure what you were looking for when I answered and that was one of the ways around the crash issue, then you could’ve just dissolved the edges you didn’t want. Go hotzt’s route and see what it says. Might be build specific too.

Thanks for the answers, and a possible work around, I don’t know how to dissolve an edge in 2.62, seems its new to 2.63 also, I don’t know, the delete menu did not give me a dissolve option, like it did in 2.63, is it like merging them?
Is it possible to dissolve all the edges so you get a face in 2.62?

BMesh is what I am having issues with, and its not in 2.62, so its a new feature; doing a little research I find others that BMesh is crashing their Blender Render; but I have two machines that it works fine on, I even complied it on this machine, its an i7 3820; I thought maybe that was it; but I still get a segment error; and the error message does not help:

[77108.040246] blender[8485]: segfault at 7f59900d5038 ip 000000000130edce sp 00007f598b929c58 error 6 in blender[400000+1655000]
[77134.924294] blender[8599] general protection ip:12fbc84 sp:7fc8600edc60 error:0 in blender[400000+1655000]
[77205.997410] blender[8706] general protection ip:12fbb47 sp:7ff0620b0c60 error:0 in blender[400000+1655000]

I created a new circle with Ngon, my guess is that its the same as hitting F, but that is a guess, it still crashes; in both Ubuntu 11.10 and 12.04; on the same machine; as I stated; I have at least two other machines this runs on with the same version of blender 2.63 from SVN.