Cloth Dynamics and Cycles

I am wondering if anyone has encountered this.

Basically I ran a cloth simulation as you would normally run it. Baked the sim to a cache file.

Now normally you can move ahead to a frame and do a test render.

But with Cycles it for some reason wants to calc the sim all over again and you get what you would normally get if you trying to go ahead to a frame that has not been simulated. A mess. And takes forever to render as it is also calculating the disaster at that frame.

Anyone seen this? Is this a known limitation/issue?

Note: This is only with F12 not with viewport preview - even from Cam view. Only F12 render.

Any solutions?

I opened a new file, set a cube as collision, and added a plane above and set for cloth, silk preset. I subdivided five times and and then set a pinning vert group with weight paint mode. Saved the file, then indicated a cache name and baked it for 100 frames. I used the timeline to scrub the animation to frame 60, and then switched to cycles render and changed to rendered view and everything was as it showed in solid view. I F12’d and got the same frame.

I am using the BF version of 2.62 from, not any new update or GA version. Windows 7 64 on i7 procsessor.

Thanks for testing Craig. I think the only thing I did different was I did not save a cache name I just let it save to the default temp location. Not sure if that makes a difference.

All my other specs are the same as yours

The only thing other that is different is that I am doing something a bit more complicated that just a simple plane and a ball.

I’ll try and save with a name and see if that changes anything.

EDIT: Yeah, well OK. It is not working for me here. Cycles wants to start the sim again and is ignoring the bake. That is what is happening in this scene. Practically freezes Blender in the process.

I did not assign any fancy materials yet, maybe it has something to do with that? I just used simple diffuse.

Ah, no. I am an idiot. I just realized I had the Subsurf modifer in the stack. When you render it subdivides the polys. (which requires another sim) Pretty sure I had it pre Cloth Mod by mistake because I imported a .lwo with it on. Just forgot it was there, and added cloth.

So my bad entirely. Nothing to do with cycles at all. :eyebrowlift:

woo hoo!

At least you found it - I didn’t know I would need ot bake subsurf modifiers on cloth objects, so that is good to know.

OK Cool. Well, actually the way it works is the modifer stack order is important - as you know -but you don’t have to bake the subsurf modifier. What I do is run the cloth sim, bake it and make sure the cloth modifer is before the subsurf modifer. I don’t usually use the subsurf on the cloth object for the simulation. The subsurf modifer subdivides the mesh at render time. So if it is before the cloth modifer then it negates the simulation because you have introduced more geometry at render time. If you want to use cloth with the subsurf modifer you can (which is what happened here by mistake) but the render subdivision level has to be the same as preview because the cloth modifer simulates based on the preview settings. So by default it is set to 1 and 3 I think and that was the issue.

Hope that makes sense.