Cloth Shrinking in 2.75 not working?

So I was testing cloth shrinking but it does not seem to be working.

  1. I have a simple cylinder here with a vertext group in the middle where I wanted it to shrink. (Pic 1)
  2. In the cloth sewing springs, I assigned this vertex group to “Shrinking” but no matter what values are in the sewing force and the min and max sliders, the cloth just does not shrink with the vertex group assigned. (Pic 2)
  3. Strange thing is, if there is no vertex group assigned to “Shrinking” the shrinking seems to work but in a very undesirable way. (Pic 3)

Is anybody else experiencing this strange problem?

Would be glad for any help!


Can someone please try to run a quick shrink simulation and tell me if it works for you?


I just tried it, and it looks ok for me …

But …
The problem is cloth collisions
It only works with self-collision enabled
I do not know why!

Best of luck


Oh thank you very much!

Issue solved! Shrinking works properly ONLY if self-collision is enabled!

Didn´t think this could have caused the issue at all.