Cloth Simulation Problem

I’ve added the subsurface modifier and made it smooth,but I don’t know why it crumples together.
Should I change some of the settings in the cloth physics tab?

Any solutions are appreciated.


There are lots of structural settings you can tweak in the cloth sim but I cannot quite see what you are trying to do
Do you have a screenshot of the cloth mesh before starting the sim?



So which settings do you think I should tweak?


I tried, with your settings, to get the cloth sim to explode, but mine was always well behaved
I thought it might be the structural stiffness, or the self collision quality, but it worked fine for me
I include the blend file so you can take a look

Best of luck


SupportClothCollision.blend (3.04 MB)

Question… Are you using an object with modeled thickness? I had tried this once before and never got it to work correctly. But then I tried going just a plane with a solidify modifier (and the sub surf) and it worked more like I expected.

Also… make sure there aren’t any intersections prior to the simulation.

Thanks @MartinNorris!
I checked out your blend file and I also changed the mass to 2. and the structural to 30.
It seems to work out fine now,I have no idea why it crumpled together.

Yes,I am using an object with modeled thickness. Thanks for your tip!

What is wrong with the cloth sim?
It doesn’t seem to be working right.

HolyCG, Can you share your .blend here?

Here it is.
Thanks for the link.


@YAFU that looks like your flag problem!
I think it is something to do with the collision since 2.73a

@HolyCG but, that aside, maybe you could tweak the collision settings for the cloth?

Hope this helps


Opps, I did not get a good screenshot - the collision settings are like …

Hi Martin.

Yes, I do not know. Now I’m a little confused.
With this file shared by HolyCG, the simulation in 2.73a have a good start but then it rebounds a lot and this part is played as if it were in slow motion at 24 fps. In opposite way, with 2.75 the simulation have a weird start but then the cloth appears to have a better rebound at the end.
The only thing I have clear is that the simulations are different comparing 2.73a and 2.74/2.75.

@Martin Norris
Thanks for testing with the cloth sim.
I didn’t get the same results though.:spin:

Yes,the cloth sims are way different compared to 2.73a.

Possibly try increasing the quality steps for the cloth {not the cloth collision ones, the ones in the cloth sub-panel}
It makes a more stable simulation, but also a bit slower and more boring.

Yeah,I changed some of the settings in the damping section too. Thank Goodness it’s OK now.

I’m still trying to find a way to get rid of those annoying lines which appeared out of nowhere.

Here it is explained how to use Subdivision Surface modifier with cloth sim:

SubSurf must be above of Cloth In the stack of modifiers when you need to give to your mesh more vertices for better simulation calculation. In this case, as shown there in “Troubleshooting”, you must use the equal subsurf level for render and preview. But be careful because if the mesh is very subdivided the simulation will be slow.
In your case the plane/mesh is subdivided enough and you do not need SubSurf above the Cloth.
The other case to use SubSurf is for soften the resulting mesh after simulation, then you add SubSurf below Cloth in the stack modifiers (perhaps 2 levels of subdivision).
And do not forget to select Smooth Shading for the mesh (but you already have it configured with Smooth Shading)

@YAFU jumped in while I was replying about subsurf - so add to his point
I normally just add a low subsurf after the cloth sim {to get rid of the strange lines and squares etc.,.}
So there is one before the cloth to increase the mesh that the sim can work with, and one after the cloth to smooth the surface nicely.

Thanks! I’ve added a SubSurf modifier and also done ‘Smooth Shade’ from the Specials menu.

@Martin Norris
Thanks! Although it doesn’t fall smoothly like a cloth should,so I’m still working on that.