Cloth tends to "stick" to collision object. How to avoid that behavior?

I have a pretty simple sim.

For me it looks really odd. Cloth try to kind of “stick” to surface of object.

Settings are default. The only think which i change is:

  1. Enable self collision for cloth.
  2. Set self collision to 0.0015 m
  3. Set quality steps and collision quality to 8

This looks like a problem with the collision thickness. There are settings for it on both the obstacle and the cloth (you already changed the self collision thickness, but there is also a setting for collisions with obstacles).

I was trying to lower Thickness outer to 0.02. It doesnt solve the problem.

Depending on the scale of the scene, you sometimes need to lower the number a lot. I tested a similar setup and only got a similar glitch when the cloth was floating a noticeable distance from the obstacle. The collision distance (on both the cloth and collider) should be lowered to the lowest value that doesn’t clip. Also, adding more subdivisions to the cloth object helped on my side.

Blender’s cloth simulator isn’t quite designed to handle extreme stretching like that. This may seem like a simple scene, but it’s a case that’s pushing the simulation outside of its intended purpose.