collision issues and terrain bug

well, iv spent literally all day working on this, and at the end of the day im left with these 2 problems specifically

  • I cant get the terrain model collision right, my player model just falls through it and lands on the next model down
  • The terrain moves when i move, similar to how the terrain moves around in minions of mirth

im posting the blend file, everything is planned to be open source if you want to keep anything, but please help
def_zone_large_1.blend (1.75 MB)

Try making the terrain static in the Physics tab, and try breaking any parenting that’s on it (Alt-P on the terrain object).

I opened your file in 2.57. All the textures are not showing up.

But your collision problems: Firstly it seems like you do not have any collision bounds set in the physics tab. You should probably set your terrain and any objects that you need to walk over to ‘Triangle mesh’. Simpler shapes should be set to a shape that matches them closer, eg a chest would probably be set on ‘Box’.

As for your character problem, it seems like your using the armature as the main object for interacting with the terrain. As I’ve seen alot on these forums, you should instead, set both the armature and the character mesh to ‘No collision’ and Make a simpler, invisible box/mesh to be your characters collsion bounds and parent the armature to it. Then put your movement logic on it, and using the shift key, select both the box and the armature, so you can link the logic to the armatures actions. This will work a alot better than trying to get an armarture to collide with the terrain, because the armature isn’t a ‘Mesh’.

I’ve modified the file and attached it. You may just want to open it up along side and copy what i’ve done yours.


def_zone_large_1_MODIFIED.blend (1.76 MB)

thank you, now i just need to work out the terrain bug, by any chance would having square polys with vertices at different angle be the cause of this? like may i need to triangulate this?

Is the problem your character is pushing through the terrain at certain places on the map? I think with objects below a certain size, the bullet physics engine has trouble calculating the collisions. I usually have my game worlds a bit bigger than the default blender grid.

Try scaling everything up (in edit mode) by 2. You will have to do a bit of object repositioning to get your world looking back to normal (sorry :/) but i just tried this and it seemed to fix the problem. :slight_smile:

I think this ‘going through the map (partially)’ problem was discussed before, and the solution was to convert the terrain’s polygons to triangles. You should be able to bring up the command with the Space button’s search menu.

that fixed it, thank you

hmm found it, Ctrl T, handy to know, thanks SolarLune.

im trying to copy what you did, but im a little lost, did you simply redo the logic bricks for the collision cube, or is there a way to link them from the armature?

im trying to copy what you did, but im a little lost, did you simply redo the logic bricks for the collision cube, or is there a way to link them from the armature?

You can just copy the logic bricks to the cube.

-Select the Cube first. Hold shift and select the armature.
-(2.57) Press space. Type Copy in the search.
-Select ‘Copy Logic Bricks to Selected’
-With them both still selected, delete all the actuators, controllers and sensors off of the Armature EXCEPT the two Action ones.
-Delete the Action actuators off of the cube.
-You can now link from the Cube to the armatures Action Actuators as you normally would when setting it up on the same object.

Also, Make sure you have the armature and mesh set to ‘no collision’ and the box set to ‘Dynamic’.


thankyou, i got it working, still a little clunky, but its coming along